Opened 14 years ago

Closed 14 years ago

#945 closed defect (invalid)

Live TV: DVB Channel tuning issues [DiSEqC]

Reported by: homer_simpson_loves_u@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords: live-tv tuning channel numbers DVB
Cc: Ticket locked: no

Description

I intend to add more details later. My laptop has freaked out on me so I can't capture logs easily at this point.

This is a repository for a few minor problems (that may be related to a major problem also documented here)

Problem 1 (minor): When Live TV is first selected, often tuning doesn't work on the first channel (default channel of default input of default card (0). A "No Lock" message is displayed with high error count (over 30000) on the OSD.

The work around has been (since 7607) to tune a channel from another switch input, forcing an update to what ever is broken. Often a lock is achieved and with older versions everything would work fine from there. However there are two issues I've observed from that.

  1. Sometimes the other channel does not lock. An error message, "Can't find PID (whatever)" appears in the log. This is a reoccuring theme, it happens often with latest SVN even after first lock. See below for the major issue related to this.
  2. Often when the "no lock" message comes up it has the wrong channel and EPG information on the OSD for the channel the frontend is attempting to tune. Sometimes when I get a lock the OSD information is wrong. When the OSD info is wrong, it displays the channel and EPG data for the previously tuned (or attempted to tune) channel.

Problem 2 (minor): The current tuned channel is not being updated faithfully under all circumstances. This is hard to describe. If I tune a channel, get a lock, and then change channels in succession each time getting a lock, and then exit live TV and re-enter live TV, the channel that gets tuned is often not the last channel viewed, but one from a few channel changes before. I hope that makes sense. This used to be much worse as it never updated the default channel in the database, now it only seems to be updating it once in a while.

Problem 3 (major): As of the late SVN 8400s channel changing has become unreliable with repeated "Can't find PID" error messages in the backend log. The only work around is to scroll to a channel on a different input and cross your fingers or a more likely fix is to exit live tv and restart it. Lock is often restored however sometimes to a channel that had been previously viewed, not the one that had most previously locked.

The third problem is difficult to clasify. Its been happening on and off when starting live tv for quite a while but once a lock was established the problem went away. With latest SVN it is no longer that easy to work around.

I can capture logs, just tell me what to look for.

Homer

Attachments (1)

myth_backend_channel_change.txt.tar.gz (24.2 KB) - added by Homer 14 years ago.
Mythbackend fails to switch to proper input

Download all attachments as: .zip

Change History (11)

comment:1 Changed 14 years ago by anonymous

I think I might have a hunch as to what's going on here.. what DVB card are you using?

comment:2 Changed 14 years ago by homer_simpson_loves_u@…

Nexus S.

with firmware: dvb-ttpci-01.fw.051005

Thanks for the help

Homer

comment:3 Changed 14 years ago by homer_simpson_loves_u@…

Well. Apparently if the frontend is on a different machine the problem doesn't happen often if at all. I ran the backend from an ssh on my laptop and the front end on my mythbox. Here is the log:

2006-01-06 00:17:10.220 Desired program #303 not found in PAT.
                        Can Not create single program PAT.
2006-01-06 00:17:10.269 Program #303 not found in PAT!
Program Association Table
 PSIP prefix(0x0) tableID(0x0) length(77) extension(0x13f)
      version(0) current(1) section(0) last_section(0)
         tsid: 319
 programCount: 17
  program number 0 has PID 0x  10   data  0x0 0x0 0x224 0x16
  program number 607 has PID 0x  21   data  0x2 0x95 0x224 0x33
  program number 609 has PID 0x  21   data  0x2 0x97 0x224 0x33
  program number 615 has PID 0x  21   data  0x2 0x103 0x224 0x33
  program number 620 has PID 0x  21   data  0x2 0x108 0x224 0x33
  program number 645 has PID 0x  21   data  0x2 0x133 0x224 0x33
  program number 32767 has PID 0x  21   data  0x127 0x255 0x224 0x33
  program number 32768 has PID 0x  21   data  0x128 0x0 0x224 0x33
  program number 36850 has PID 0x  21   data  0x143 0x242 0x224 0x33
  program number 36851 has PID 0x  21   data  0x143 0x243 0x224 0x33
  program number 36854 has PID 0x  21   data  0x143 0x246 0x224 0x33
  program number 36855 has PID 0x  21   data  0x143 0x247 0x224 0x33
  program number 36856 has PID 0x  21   data  0x143 0x248 0x224 0x33
  program number 36857 has PID 0x  21   data  0x143 0x249 0x224 0x33
  program number 36859 has PID 0x  21   data  0x143 0x251 0x224 0x33
  program number 36860 has PID 0x  21   data  0x143 0x252 0x224 0x33
  program number 36863 has PID 0x  21   data  0x143 0x255 0x224 0x33


2006-01-06 00:17:10.269 Desired program #303 not found in PAT.
                        Can Not create single program PAT.
2006-01-06 00:17:10.295 TVRec(1): Changing from WatchingLiveTV to None
2006-01-06 00:17:10.371 Program #303 not found in PAT!
Program Association Table
 PSIP prefix(0x0) tableID(0x0) length(77) extension(0x13f)
      version(0) current(1) section(0) last_section(0)
         tsid: 319
 programCount: 17
  program number 0 has PID 0x  10   data  0x0 0x0 0x224 0x16
  program number 607 has PID 0x  21   data  0x2 0x95 0x224 0x33
  program number 609 has PID 0x  21   data  0x2 0x97 0x224 0x33
  program number 615 has PID 0x  21   data  0x2 0x103 0x224 0x33
  program number 620 has PID 0x  21   data  0x2 0x108 0x224 0x33
  program number 645 has PID 0x  21   data  0x2 0x133 0x224 0x33
  program number 32767 has PID 0x  21   data  0x127 0x255 0x224 0x33
  program number 32768 has PID 0x  21   data  0x128 0x0 0x224 0x33
  program number 36850 has PID 0x  21   data  0x143 0x242 0x224 0x33
  program number 36851 has PID 0x  21   data  0x143 0x243 0x224 0x33
  program number 36854 has PID 0x  21   data  0x143 0x246 0x224 0x33
  program number 36855 has PID 0x  21   data  0x143 0x247 0x224 0x33
  program number 36856 has PID 0x  21   data  0x143 0x248 0x224 0x33
  program number 36857 has PID 0x  21   data  0x143 0x249 0x224 0x33
  program number 36859 has PID 0x  21   data  0x143 0x251 0x224 0x33
  program number 36860 has PID 0x  21   data  0x143 0x252 0x224 0x33
  program number 36863 has PID 0x  21   data  0x143 0x255 0x224 0x33


2006-01-06 00:17:10.371 Desired program #303 not found in PAT.
                        Can Not create single program PAT.
2006-01-06 00:17:10.398 Finished recording Inside the NFL: channel 2303
2006-01-06 00:17:10.451 Finished recording Inside the NFL: channel 2303
                                                                             

I haven't turned on any verbose messaging, if I should let me know.

Homer

comment:4 Changed 14 years ago by Stuart Auchterlonie

The program not found in PAT problem is a duplicate of #743

I'm going to try and rewrite the patch for that in the next week.

comment:5 Changed 14 years ago by homer_simpson_loves_u@…

Thanks Stuart. I'll try to apply the patch from #743 tonight and see if it makes the pid and old OSD information problem go away...

Homer

comment:6 Changed 14 years ago by Isaac Richards

Owner: changed from Isaac Richards to danielk

comment:7 Changed 14 years ago by danielk

Milestone: 0.190.20
Summary: Live TV: DVB Channel tuning issuesLive TV: DVB Channel tuning issues [DiSEqC]

I'm not so sure this is a duplicate of #743; I think Homer is actually getting these error messages because of a MythTV bug, not the driver bug #743 tries to work around.

It appears related to #973 to me, it looks like the DiSEqC commands aren't getting to the switch.

Homer can you confirm that you have DiSEqC?

Also what kind of switch is this and what is on each input of the switch?

The next step is to produce a backend log with "-v record,siparser,channel". Start LiveTV, wait about 60 seconds, switch to another channel that should come in, wait for it to come in, wait 5 seconds, then exit LiveTV. This should let me see if MythTV is reporting some kind of error, or behaving strangely before the error messages you posted.

comment:8 Changed 14 years ago by homer_simpson_loves_u@…

Its like a DiSEqC. Its a Legacy Switch 64 used in the past by a satelite provider in the US. Its fully supported by the kernel.

Before I get to the log, I want to mention another bug. Sometimes when I get a lock I get black screen, data is obviously recording (hard drive activity), but nothing comes out of the front end. I don't know if its related.

I captured a failed tune to Channel 213 from Channel 503. It took a few channel changes to get it to fail. Ironically, I wanted to make sure I could get 213 to lock and it took me a long time to get it to lock. I had to get another channel on the same switch input to lock and then change to 213. However it does work, when it locks.

I have several patches in place in the mythtv code to work for me. The Legacy switch patch is one and its rather simple, one is US provider EIT and the other is obvious so I won't mention it.

I will attach an edited log (-v record,channel,siparser) from the failed to tun 213.

Homer

Changed 14 years ago by Homer

Mythbackend fails to switch to proper input

comment:9 Changed 14 years ago by homer_simpson_loves_u@…

I just looked through the log and I can see that Mythbackend is choosing the wrong switch input. I don't know why though. It should choose input 2, not input 1. It is interesting to note that I'm changing from an EIT channel to a non-eit channel, but I don't think that is related to this problem. Also, when it fails to lock on one switch input, I can only get it to lock again by choosing a channel on another switch input. And since only the up and down keys work, that sometimes takes a little scrolling through numbers.

If you need more of the log (leading up to this point) let me know I have it.

Or if you need other information, let me know.

Thanks for checking this out.

Homer

comment:10 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

Its like a DiSEqC. Its a Legacy Switch 64 used in the past by a satelite provider in the US. Its fully supported by the kernel.

Hmmmm, you are going to have to submit the patch to support this switch before filing a bug... If you need help getting it to work, as appears to be the case please e-mail the dev list.

Note: See TracTickets for help on using tickets.