Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#9475 closed Bug Report (Duplicate)

[CRASH] ISO image playback crashes frontend

Reported by: finlay@… Owned by: danielk
Priority: trivial Milestone: unknown
Component: MythTV - DVD Playback Version: 0.24-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description (last modified by Raymond Wagner)

Trying to play a dvd iso image from a storage group crashed the frontend. I'll attach the mythfrontend.log file and a crash dump

Attachments (4)

log.bz2 (27.7 KB) - added by John Finlay <finlay@…> 9 years ago.
mythfrontend.log compressed with bzip2
_usr_bin_mythfrontend.real.1000.crash (83.2 KB) - added by John Finlay <finlay@…> 9 years ago.
mythfrontend crash dump
gdb.txt (48.2 KB) - added by John Finlay <finlay@…> 9 years ago.
gdb backtrace
version_info (672 bytes) - added by Raymond Wagner 9 years ago.

Download all attachments as: .zip

Change History (20)

Changed 9 years ago by John Finlay <finlay@…>

Attachment: log.bz2 added

mythfrontend.log compressed with bzip2

Changed 9 years ago by John Finlay <finlay@…>

mythfrontend crash dump

comment:1 Changed 9 years ago by robertm

Status: newinfoneeded_new

As mentioned to you on the users list, please submit an actual crash backtrace per the wiki debugging page.

comment:2 Changed 9 years ago by robertm

Component: Plugin - MythVideoMythTV - DVD Playback
Milestone: 0.24.1unknown
Priority: majortrivial
Severity: highlow

Also, not a mythvideo problem, and please read the ticket howto-- A developer will decide what the deadline for solving a problem, and its severity, is.

comment:3 in reply to:  1 Changed 9 years ago by John Finlay <finlay@…>

Replying to robertm:

As mentioned to you on the users list, please submit an actual crash backtrace per the wiki debugging page.

Isn't that what the crash dump I attached is?

comment:4 Changed 9 years ago by robertm

No. Please read the wiki debugging page you were linked on your mailing list thread.

comment:5 in reply to:  4 Changed 9 years ago by John Finlay <finlay@…>

Replying to robertm:

No. Please read the wiki debugging page you were linked on your mailing list thread.

I did and under the section on using ubuntu debug packages in Basic Backtrace it says:

4) When your crash happens, it will ask you to submit a bug report. Submit the full report. You'll need a launchpad account for this.

That didn't happen so I found the crash dump and sent it but I suppose you mean that I'm supposed to run mythfrontend gdb?

comment:6 Changed 9 years ago by robertm

We don't have access to Ubuntu's crash report stuf. Presumably their tool has somehow automatically opened a bug report that they will theoretically forward to us-- for *us* to handle the ticket, though, we need a proper backtrace, and yes, that means attaching gdb to a debug build of MythTV *with debug symbols*. (This means you will need to have installed all the debug packages). Install a debug build and follow the normal gdb backtrace steps.

Changed 9 years ago by John Finlay <finlay@…>

Attachment: gdb.txt added

gdb backtrace

comment:7 Changed 9 years ago by robertm

This is a SIGABRT, not a SIGSEGV.... did you cause it to crash, or just kill the frontend while it was running? To be clear, the backtrace output needs to be from when you trigger a frontend crash.

comment:8 Changed 9 years ago by robertm

Owner: changed from robertm to danielk

Daniel, this appears that it might be a Ringbuffer issue-- can you have a look?

comment:9 in reply to:  7 Changed 9 years ago by John Finlay <finlay@…>

Replying to robertm:

This is a SIGABRT, not a SIGSEGV.... did you cause it to crash, or just kill the frontend while it was running? To be clear, the backtrace output needs to be from when you trigger a frontend crash.

I ran the frontend in gdb and then navigated to start playing an iso image - the frontend rand and then crashed with the info included in the dump. I used the gdbcommands setup listed in the HOW-TO. I did not abort it or otherwise do anything to make it crash. It looks like an assert in some mutex handling code triggered it.

comment:10 Changed 9 years ago by finlay@…

I made two iso files from the same dvd but using two different ripping programs (DVDFAB and DVDShrink). The frontend can play the one iso image (DVDFab) just fine but crashes when the other iso image (DVDShrink) is played. I mounted the iso images using loopback devices and md5summed the VIDEO_TS files to see what the difference was. All the .VOB files are identical but the .IFO files are different. I used lsdvd to dump the info about the iso images and the output was the same for both. I suspect that the FE is having a problem reading the .IFO file information and analyzing it.

comment:11 Changed 9 years ago by Raymond Wagner

Description: modified (diff)

Changed 9 years ago by Raymond Wagner

Attachment: version_info added

comment:12 Changed 9 years ago by beirdo

Summary: ISO image playback crashes frontend[CRASH] ISO image playback crashes frontend

comment:13 Changed 9 years ago by robertm

Status: infoneeded_newnew

comment:14 Changed 9 years ago by skd5aner <skd5aner@…>

ref #9844 - Possible related?

comment:15 Changed 8 years ago by sphery

Resolution: Duplicate
Status: newclosed

I'm marking this as a duplicate of #9844, based on:

2011-01-12 14:08:40.047 RingBuf?(myth://Videos@172.20.2.3:6543/Kyle XY/KyleXY_S1_D1.ISO): OpenFile?(myth://Videos@172.20.2.3:6543/Kyle XY/KyleXY_S1_D1.ISO, 2000 ms)

(with capital .ISO). If this is not fixed in current (as of today) -fixes, please re-open with new logs and backtrace. Thanks. (And thank you, skd5aner, for noticing the similarities.)

comment:16 Changed 8 years ago by sphery

Note: See TracTickets for help on using tickets.