Opened 9 years ago

Closed 6 years ago

#9494 closed Bug Report - General (Duplicate)

Mac MythTV port should ignore remote events when screen is blanked

Reported by: dgatwood@… Owned by: JYA
Priority: minor Milestone: 0.28
Component: Ports - OSX Version: 0.23-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

If you use screen blanking on Mac OS X, MythTV dutifully wakes the screen (maybe accidentally) when you hit a button on the Apple remote, but it then interprets that button press, resulting in an action that the user can't possibly have intended (because the user is acting blindly).

You can probably solve this by calling CGDisplayIsAsleep() on the main display and throwing away the event if that returns true. That said, I'm not certain of this; the display might already be awake by the time you get that event, in which case you would have to use... probably CGDisplayRegisterReconfigurationCallback (and, later, CGDisplayRemoveReconfigurationCallback) to register for notifications so that you can throw away events for... say a second after receiving notification that the display is active (drawable).

Either way, it's not a major bug, more of a "nice to have" that would improve usability.

Change History (11)

comment:1 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Invalid
Status: newclosed

dgatwood, thank you for the report. I'm considering this a feature request and not a bug report, and therefore I'm closing it as such.

From your description it sounds like you have already looked at the code and have an idea of what needs to be done to implement the feature. If you're able to implement this feature, feel free to reopen this ticket and attach a patch - that will highly increase the chance of getting a developer to look into it. Thanks.

Feature requests (without patches) are tracked at http://www.mythtv.org/wiki/Feature_Wishlist

comment:2 Changed 9 years ago by dgatwood@…

I respectfully disagree. It's not a feature. It's a correctness issue. When you press a button to wake the machine or undim the screen, you do not expect the software to take action based on that keypress or button press because the menu you're acting on isn't visible. If the app takes an action based on such a keypress or button press, that's a bug.

Sadly, it would require too much effort to get permission from my employer to submit a patch. Otherwise, I would have done so already. Sorry. The best I can do is point you at the right APIs.

comment:3 Changed 9 years ago by Stuart Auchterlonie

Milestone: unknown0.25
Resolution: Invalid
Status: closednew

I've seen this, so i'll take a look.

comment:4 Changed 9 years ago by Stuart Auchterlonie

Owner: set to Stuart Auchterlonie
Status: newassigned

comment:5 Changed 8 years ago by stuartm

Component: MythTV - GeneralPorts - OSX

comment:6 Changed 8 years ago by stuartm

Type: Bug ReportBug Report - General

This one is going nowhere fast without a patch

comment:7 Changed 8 years ago by Stuart Auchterlonie

Milestone: 0.250.26

Some hacking will be required on this one to develop a suitable patch.

comment:8 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Milestone: 0.260.26.1

comment:9 Changed 7 years ago by Stuart Auchterlonie

Owner: Stuart Auchterlonie deleted
Status: assignednew

I can't do anything with this anymore. My mac is now the Fedora 17 buildbot due to not being able to get a compiler to build mythtv on osx anymore.

If anyone wants to work on the mac port they can have this.

Stuart

comment:10 Changed 6 years ago by paulh

Milestone: 0.26.10.28
Owner: set to JYA
Status: newassigned

comment:11 Changed 6 years ago by stuartm

Resolution: Duplicate
Status: assignedclosed

Duplicate of #10789

Note: See TracTickets for help on using tickets.