Opened 14 years ago

Closed 14 years ago

#951 closed defect (invalid)

svn 8513 frontend segfaults when starting to display a HDTV recording or livetv

Reported by: mythfrontend crash when viewing HD Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by danielk)

Running Debian sid kernel 2.6.15 Xorg 6.9 on dell inspiron 2200 laptop. Will display SD files recorded with pvr-150 but any HD will segfault.

0000:00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
0000:00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
0000:00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
0000:00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
0000:00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
0000:00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
0000:00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
0000:00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
0000:00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
0000:00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
0000:00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
0000:02:01.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
0000:02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
0000:02:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller Mobile (rev 03)

crashed everytime you try to view HD.

Attachments (1)

lo.gz (22.1 KB) - added by spam 14 years ago.
vargrind debug file

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by spam

Attachment: lo.gz added

vargrind debug file

comment:1 Changed 14 years ago by danielk

Description: modified (diff)
Milestone: unknown
Resolution: invalid
Status: newclosed

Please attach a backtrace and reopen.

Please also check if this might be a duplicate of #929.

comment:2 Changed 14 years ago by spam

Resolution: invalid
Status: closedreopened

Compiled with debug and valgrind log is in attachment lo.gz It's the frontend segfault not the backend like #929

comment:3 Changed 14 years ago by spam

Resolution: invalid
Status: reopenedclosed

The problem was with the Xorg i810 driver. removed the dri and glx modules in the xorg.conf. Can now play HD ts files with mplayer -vo xv and mythtv.

Note: See TracTickets for help on using tickets.