Opened 9 years ago

Closed 9 years ago

#9526 closed Bug Report (Fixed)

[HANG] "Watch TV" (LiveTV) hangs frontend, shuts down DNS on remote

Reported by: Larry Johnson <keepitsimpleengineer@…> Owned by:
Priority: minor Milestone: 0.24.1
Component: MythTV - Video Playback Version: 0.24-fixes
Severity: medium Keywords: livetv
Cc: Ticket locked: no

Description

This is new behavior. The local system ran for 19 days unattended while I was away, and this behavior occurred upon return.

Selecting "Watch TV" (Live-TV) from the starting Mythtv window opens the splash screen with "Please Wait..." and hangs. This behavior occurs on both local and remote frontends.

On the remote system after Mythtv hang, pinging any website by site name fails with host not found. Ping with IP address succeeds. Closing the window on the remote still leaves frontend processes running, and the frontend cannot be restarted unless the frontend processes are restarted with a SIGTERM. After closing the frontend processes with a SIGTERM ping behavior is normal and the frontend can be restarted.

The backend can record OTA successfully and they can be watched using "Media Library".

Booting the local machine with Windows 7 Media Center LiveTV functions normally.

version info attached; apport bug report attached for remote system.

Ubuntu 10.10, Hauppage 2250, local: nvidia GT260, remote: nvidia GT240

Attachments (5)

mythtv-version-info.txt (2.2 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
bug.apport.tar.7z (242.6 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
tail-mythfrontend.log (2.1 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
for fixes/0.24 (v0.24-138-g14bfdc3)
termout-frontend-reset.txt (1.7 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
tail-verbose-mythfrontend.log.tar.7z (25.4 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Attachment: mythtv-version-info.txt added

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Attachment: bug.apport.tar.7z added

comment:1 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Updated to version fixes/0.24 (v0.24-138-g14bfdc3)

Remote still hangs at "Please wait…"

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Attachment: tail-mythfrontend.log added

for fixes/0.24 (v0.24-138-g14bfdc3)

comment:2 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

On the remote client system, I ran frontend -r, termout attached.

I changed session-setting to 'MYTHFRONTEND_OPTS="--verbose all,nodatabase"' and ran mythfrontend --service, log attached.

Frontend hangs.

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Attachment: termout-frontend-reset.txt added

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

comment:3 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Updated to v0.24-146-g51e3486, same behavior.

Last edited 9 years ago by Raymond Wagner (previous) (diff)

comment:4 Changed 9 years ago by robertm

Please don't update the ticket every time you update. We'll let you know if we need anything further.

comment:5 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

No longer not working.

:~$ mythbackend --version MythTV Version : v0.24-159-gb259732 MythTV Branch : fixes/0.24 :~$ mythfrontend --version MythTV Version : v0.24-159-gb259732 MythTV Branch : fixes/0.24

comment:6 Changed 9 years ago by beirdo

Summary: "Watch TV" (LiveTV) hangs frontend, shuts down DNS on remote[HANG] "Watch TV" (LiveTV) hangs frontend, shuts down DNS on remote

I do not see how the DNS portion can possibly be caused by MythTV. That sounds more like a dhcpd that died somewhere on your network, and that machine couldn't renew its IP address.

comment:7 Changed 9 years ago by beirdo

Component: MythTV - GeneralMythTV - Video Playback
Status: newinfoneeded_new

The remainder of this ticket seems to be right along the lines of something markk recently fixed. Try updating to the tip of the fixes/0.24 branch, and try again. Please let us know if this is now solved.

comment:8 in reply to:  7 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Replying to beirdo:

The remainder of this ticket seems to be right along the lines of something markk recently fixed. Try updating to the tip of the fixes/0.24 branch, and try again. Please let us know if this is now solved.

comment:9 in reply to:  7 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Replying to beirdo:

The remainder of this ticket seems to be right along the lines of something markk recently fixed. Try updating to the tip of the fixes/0.24 branch, and try again. Please let us know if this is now solved.

I see now that my earlier report was very unclear. As of… :~$ mythbackend --version MythTV Version : v0.24-159-gb259732 MythTV Branch : fixes/0.24 :~$ mythfrontend --version MythTV Version : v0.24-159-gb259732 MythTV Branch : fixes/0.24 …it has been working.

comment:10 Changed 9 years ago by sphery

Milestone: unknown0.24.1
Resolution: Fixed
Status: infoneeded_newclosed

Fixed by recent Live TV fixes.

Thanks for reporting back.

Note: See TracTickets for help on using tickets.