Opened 10 years ago

Closed 10 years ago

#9585 closed Bug Report (Invalid)

Frontend hangs on starting playback if "Enter" is hit twice

Reported by: dmtv@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I started picking up the nightly builds for the 0.24-fixes stream via Mythbuntu late last year. An update in late January (roughly) seems to have introduced a serious defect that was not there in the past.

On the "Watch Recordings" screen, if I hit "Enter" to start the playback of a recording there is a slight delay before the playback starts. If the machine is busy, this can take a few seconds. As a result, I often think that the (cheap wireless keyboard's) keystroke did not register and hit "Enter" again. This has never been a problem until recently.

For the past few weeks, hitting "Enter" a second time before the recording starts causes the frontend to hang every time. It needs to be killed and restarted. This happens several times a day, and every time my three-year-old has the controls. It happens when watching live TV, too, but I haven't really tried to reproduce it reliably there, as I imagine it is the same problem as when watching recordings.

Maybe it always did this (but I think not): recently the audio starts fractionally before the video appears when a recording is played back. Hitting "Enter" twice results in a fraction of a second of audio before the frontend hangs. The "Watch Recordings" screen is still displayed (the video has not yet appeared) and the frontend is completely unresponsive (forever, until restarted).

It should be easy enough to reproduce this problem and confirm this bug report. However, you may need to place the machine under some load first, to ensure that there is time to hit "Enter" twice before the video appears.

Change History (3)

comment:1 Changed 10 years ago by robertm

Resolution: Invalid
Status: newclosed

Please update to current .24-fixes. Your problem was solved several days ago.

comment:2 Changed 10 years ago by robertm

Resolution: Invalid
Status: closednew

Actually going to reopen for a moment, as it looks like the fix may not have yet been backported.

comment:3 Changed 10 years ago by robertm

Resolution: Invalid
Status: newclosed

Nope, I like, was backported several days ago as I thought, https://github.com/MythTV/mythtv/commit/18a8200d24303b9bfddf7e78f482c576ba78ed85

Please update to newer .24-fixes.

Note: See TracTickets for help on using tickets.