Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9591 closed Bug Report (fixed)

segmentation fault in qt on play in mythmusic.

Reported by: hcoin@… Owned by: paulh
Priority: major Milestone: 0.24.1
Component: Plugin - MythMusic Version: 0.24-fixes
Severity: high Keywords: segmentation fault play qt4 mythmusic
Cc: Ticket locked: no

Description

Mythmusic crashes with a segmentation fault every time, just at the moment playback begin is attempted. Navigation route: Launch mythfrontend at the keyboard, attempt to play using 'all my music', navigating to a single music file, hit 'enter' and crash-- back to a command prompt and the end of mythfrontend. Tried classic and ubuntu themes, same result. System has a couple of dual ported video cards with monitors attached to each.

TV recordings at both SD & HD , dvd/video playback all normal. Output is digital spdif/iec on an ICH5 chip. Rhythmbox plays the same music library without problem on the same system out the digital port.

System is Debian Squeeze, qt4, kernel 2.6.32-6-686 and all the mythfrontend terminal and gdb reports, including stack backtrace details are here:

http://pastebin.com/2a3vzBYP

The clip right around the fault report is:

1.

2011-02-11 14:22:17.246 XMLParse: LoadTheme? using '/usr/share/mythtv/themes/Mythbuntu/music-ui.xml'

2.

2011-02-11 14:22:22.622 AO: Opening audio device 'plug:spdif:0' ch 2(2) sr 44100 sf signed 16 bit reenc 0

3.

[New Thread 0xaacffb70 (LWP 18611)]

4.

5.

Program received signal SIGSEGV, Segmentation fault.

6.

0xb5e42ef8 in QString::operator=(QString const&) () from /usr/lib/libQtCore.so.4

7.

(gdb) bt

8.

#0 0xb5e42ef8 in QString::operator=(QString const&) () from /usr/lib/libQtCore.so.4

9.

#1 0xaa0f0fbc in MusicPlayer::decoderHandlerReady() () from /usr/lib/mythtv/plugins/libmythmusic.so

10.

#2 0xaa0f2f98 in MusicPlayer::customEvent(QEvent*) () from /usr/lib/mythtv/plugins/libmythmusic.so

11.

#3 0xb5f05e5c in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4

I've reinstalled qt4, removed as much of qt3 as I could, thought it was an ALSA thing for a bit having to do with upconverting 44.1 cd flac file to 48K for the ICH5, but if that's so why would all the other music programs work playing back the same file w/alsa? So, out of clues. Posted on the user's list, no responses.

Thanks!

Harry

Attachments (4)

dmesg.txt (50.3 KB) - added by hcoin@… 8 years ago.
dmesg output
mythfrontendlog.txt (8.5 KB) - added by hcoin@… 8 years ago.
Mythfrontend -v playback
myth.log (8.4 KB) - added by hcoin@… 8 years ago.
gdb's myth.log with thread info
gdb.txt (22.8 KB) - added by hcoin@… 8 years ago.
gdb.txt from above myth log with full thread info

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by hcoin@…

Attachment: dmesg.txt added

dmesg output

comment:1 Changed 8 years ago by paulh

Can you please run the frontend with mythfrontend -v playback and attach the output.

Changed 8 years ago by hcoin@…

Attachment: mythfrontendlog.txt added

Mythfrontend -v playback

comment:2 Changed 8 years ago by hcoin@…

I did

mythfrontend -v playback 2>&1 > mythfrontendlog.txt

and attached it. I manually appended the 'segmentation fault' which appeared on the monitor but wasn't added to the file. During the run, I launched the frontend, navigated by keyboard to music, 'all my music', picked a composer whose name started with 'a', picked a bit of Beethoven's 5th, and didn't hear a note of it before the crash you see.

comment:3 Changed 8 years ago by paulh

OK, thanks. All looks normal.

I don't see anything obvious in MusicPlayer::decoderHandlerReady() that could be causing this segfault. I'm going to need a full bt with line numbers to see exactly where it's crashing. That would also tell me what the other threads are doing since I suspect it may be something to do with accessing a QString in more than one thread at a time. http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

Changed 8 years ago by hcoin@…

Attachment: myth.log added

gdb's myth.log with thread info

comment:4 Changed 8 years ago by hcoin@…

Same UI steps as before. I don't have the sources, execs stable from debian-multimedia.

Changed 8 years ago by hcoin@…

Attachment: gdb.txt added

gdb.txt from above myth log with full thread info

comment:5 Changed 8 years ago by paulh

Resolution: Fixed
Status: newclosed

(In 23eff84c0)

Fix a segfault in MusicPlayer::decoderHandlerReady().

Any track with 'cda' in the filename was causing problems. This just uses a more sane way to detect if the decoder is a Cddecoder. Fixes #9591.

comment:6 Changed 8 years ago by paulh

(In 84db96ce5)

Fix a segfault in MusicPlayer::decoderHandlerReady().

Any track with 'cda' in the filename was causing problems. This just uses a more sane way to detect if the decoder is a Cddecoder. Fixes #9591.

(cherry picked from commit 23eff84c01c4494e2961b1ba0494c45e80d36053)

comment:7 Changed 8 years ago by paulh

Milestone: unknown0.24.1

comment:8 Changed 8 years ago by hcoin@…

Bug source (not fix) confirmed. Changed music library path from /home/library/cdarchive to /home/library/musicarchive and it worked.

comment:9 Changed 8 years ago by Paul Harrison

Resolution: Fixedfixed

Fix a segfault in MusicPlayer::decoderHandlerReady().

Any track with 'cda' in the filename was causing problems. This just uses a more sane way to detect if the decoder is a Cddecoder. Fixes #9591.

Changeset: 23eff84c01c4494e2961b1ba0494c45e80d36053

Note: See TracTickets for help on using tickets.