Opened 9 years ago

Closed 7 years ago

#9593 closed Bug Report - General (Won't Fix)

Teletext subtitles not working properly for Scandinavian Canal+ movie channels

Reported by: Jari Nevalainen <jari.nevalainen@…> Owned by: Jim Stichnoth
Priority: minor Milestone: 0.27
Component: MythTV - Captions Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When watching Scandinavian Canal+ movie channels (Canal First, Canal Hits, Canal Drama etc.) the teletext subtitles are partly skipped or shown so quickly that it's hard to read them.

I've taken a short example from one of the channels and it's located here: http://www.kennelpoika.net/myth/House.mpg (26Mb)

Also, the exact subtitles taken with Project X and included with my english translation and explanation what is shown and what is skipped can be found from here: http://www.kennelpoika.net/myth/house_dialogs_explained.txt

Interestingly, this problem is only with the movie channels. For example Star and BBC channels don't have this problem even though they are from the same service provider. The transmission is DVB-S.

Change History (11)

comment:1 Changed 9 years ago by markk

Owner: set to markk
Status: newaccepted

Jari - for clarity, can you confirm you are using the Finnish subtitle track? and that your locale is set to Finland - and hence it defaults to the Finnish track when subtitles are enabled.

comment:2 Changed 9 years ago by Jari Nevalainen <jari.nevalainen@…>

Yes, that is the case.

comment:3 Changed 9 years ago by markk

Jari - I've spent some time looking at this and I'm no closer to finding a fix. Can you confirm those subtitles work as expected when using a set top box or television?

Notes:

For a given magazine, a page starts with a page header, followed by a number of data packets and is considered complete when another page header for the same magazine is received.

For the above clip, the Finnish subtitles are on magazine 6 and by and large there is only one page in that magazine (1689). Hence that magazine is only receiving page headers for that one page. For certain subs, a page header is received and is followed almost immediately by a data (subtitle) packet. The next page header is then not received for 3-4 seconds, at which point that subtitle is either then displayed only briefly or immediately replaced by the next.

It looks like those subs should be displayed almost as they are received but they do not match the transmission model of header->packet->header. There are additional flags that we do not appear to do anything with - which may be the problem - or (less likely), the demuxer is presenting those packets out of order; which would explain the timing problem.

comment:4 Changed 9 years ago by Jari Nevalainen <jari.nevalainen@…>

Yes, they work perfectly with VDR and Canal+' own box. I'd of course like to stick with MythTV :)

comment:5 Changed 8 years ago by markk

Owner: markk deleted
Status: acceptedassigned

comment:6 Changed 8 years ago by danielk

Owner: set to danielk

comment:7 Changed 8 years ago by Jim Stichnoth

Component: MythTV - GeneralMythTV - Captions

comment:8 Changed 8 years ago by stuartm

Milestone: unknown0.25
Owner: changed from danielk to Jim Stichnoth
Type: Bug ReportBug Report - General

comment:9 Changed 8 years ago by Jim Stichnoth

Milestone: 0.250.26
Status: assignedaccepted

Jari,

I can reproduce the behavior on your test clip in Master. Can you confirm whether recent Canal+ broadcasts still have this problem? (in either 0.24 or Master)

I'm changing the milestone to 0.26 based on the timing of the 0.25 release, my low level of teletext experience, and of course the fact that Mark looked at it and didn't fix it.

comment:10 Changed 7 years ago by Jim Stichnoth

Milestone: 0.260.27

comment:11 Changed 7 years ago by Jim Stichnoth

Resolution: Won't Fix
Status: acceptedclosed

Please reopen, or open a new ticket, if this continues to be a problem. Otherwise I am very unlikely to look into this more.

Note: See TracTickets for help on using tickets.