Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9620 closed Bug Report - General (Fixed)

segfault / abort mythvideo in browse view

Reported by: managementboy@… Owned by: paulh
Priority: minor Milestone: 0.25
Component: MythTV - User Interface Library Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

My frontend crashes consistantly when changing to the browse view in mythvideo and moveing to a different directory. Tried it with several themes, same issue. Attached the gdb file and the output of mythtv

mythfrontend version: master [v0.25pre-1281-g92e8e19]

Attachments (4)

gdb.tar.bz2 (195 bytes) - added by managementboy@… 7 years ago.
gdb output
crash.tar.bz2 (196 bytes) - added by managementboy@… 7 years ago.
log of mythfrontend -v most
crash.log (4.4 KB) - added by managementboy@… 7 years ago.
replacement
gdb.txt (53.4 KB) - added by managementboy@… 7 years ago.
replacement

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by managementboy@…

Attachment: gdb.tar.bz2 added

gdb output

Changed 7 years ago by managementboy@…

Attachment: crash.tar.bz2 added

log of mythfrontend -v most

comment:1 Changed 7 years ago by robertm

Status: newinfoneeded_new

This backtrace isn't a valid text file, are you sure you compressed it properly? Why not just attach it as a text file so it's not necessary to download it to look at it?

comment:2 in reply to:  1 Changed 7 years ago by managementboy@…

Replying to robertm:

This backtrace isn't a valid text file, are you sure you compressed it properly? Why not just attach it as a text file so it's not necessary to download it to look at it?

ohh crap. I will attach a new one tonight. sorry.

Changed 7 years ago by managementboy@…

Attachment: crash.log added

replacement

Changed 7 years ago by managementboy@…

Attachment: gdb.txt added

replacement

comment:3 Changed 7 years ago by managementboy@…

tested it yesterday, issue is still in most current trunk.

Please attach all output as a file in bug reports. MythTV Version : v0.25pre-1794-g562936b MythTV Branch : master Network Protocol : 65 Library API : 0.25.20110414-3 QT Version : 4.7.0 Options compiled in: linux debug use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_php using_dvb using_firewire usi ng_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_qtdbus using_qtwebkit using_v 4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_ mheg

comment:4 Changed 7 years ago by robertm

Component: Plugin - MythVideoMythTV - User Interface Library
Owner: changed from robertm to stuartm
Status: infoneeded_newassigned

MythUIButtonTree Crash.

comment:5 Changed 7 years ago by Github

MythUIButtonTree: Fix an abort when scrolling.

The sanity checks in SetTreeState?() were wrong causing an occasional abort when scrolling around. This actually fixes the crash in ticket #9620 but the root cause still remains which is the wrong node somehow gets the focus after the tree is assigned if the top level node has two or more nodes. Refs #9620.

Branch: master Changeset: 5ff3b8bbea2c61b2e87a0e6c55cd12ebf8d885d3

comment:6 Changed 7 years ago by paulh

Milestone: unknown0.25
Resolution: Fixed
Status: assignedclosed
Version: UnspecifiedTrunk Head

This is fixed in master the remaining issue is a problem with MythVideo? which will be fixed as part of #7425.

comment:7 Changed 7 years ago by paulh

Owner: changed from stuartm to paulh
Note: See TracTickets for help on using tickets.