Opened 7 years ago

Closed 7 years ago

#9634 closed Bug Report - Crash (Unverified)

[CRASH] segfault in ImageLoadThread::run

Reported by: brian@… Owned by: beirdo
Priority: blocker Milestone: unknown
Component: MythTV - User Interface Library Version: 0.24-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description

Using 0.24-fixes from today, I am getting a pretty consistent segfault trying to start viewing a particular program.

The stack trace of the active thread in gdb when it segfaults:

#0  0x0a5e2e60 in ?? ()
#1  0x0053f0b3 in ImageLoadThread::run (this=0xb3cf790) at mythuiimage.cpp:104
#2  0x01a6625c in QThreadPoolThread::run (this=0x9bffa58) at concurrent/qthreadpool.cpp:106
#3  0x01a7132e in QThreadPrivate::start (arg=0x9bffa58) at thread/qthread_unix.cpp:248
#4  0x018e596e in start_thread (arg=0xa9bdfb70) at pthread_create.c:300
#5  0x01e72a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

I will attach the full threaded backtrace.

Attachments (1)

ThreadStacktrace.txt (97.1 KB) - added by brian@… 7 years ago.
threaded back trace of crash

Download all attachments as: .zip

Change History (15)

Changed 7 years ago by brian@…

Attachment: ThreadStacktrace.txt added

threaded back trace of crash

comment:1 Changed 7 years ago by cpinkham

Owner: set to cpinkham
Status: newassigned

comment:2 Changed 7 years ago by beirdo

Owner: changed from cpinkham to beirdo
Status: assignedaccepted
Version: Unspecified0.24-fixes

comment:3 Changed 7 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: acceptedclosed

Initialize the MythUIImage filename correctly

Fixes #9634. Fixes #9708. Refs #9547.

If the filename does not start with "/", "http://", "https://" or "ftp://", then the actual filename loaded is uninitialized. It can be any random crap on the stack. I'm honestly surprised this worked at all :)

This may fix things for #9547 as well, and should be tested with that scenario too.

Branch: master Changeset: 2c7735e7f80b5d2737d2bc8c4e9144f3e42da2e7

comment:4 Changed 7 years ago by beirdo

Milestone: 0.250.24.2

comment:5 Changed 7 years ago by beirdo

Milestone: 0.24.2unknown
Resolution: fixed
Status: closednew

It's worth trying the re-fixed code, but the above commit got reverted.

comment:6 Changed 7 years ago by beirdo

Priority: blockermajor

comment:7 Changed 7 years ago by beirdo

Summary: segfault in ImageLoadThread::run[CRASH] segfault in ImageLoadThread::run

comment:8 Changed 7 years ago by beirdo

Status: newinfoneeded_new

Is this still happening in the particular test case that was cited in the ticket?

comment:9 Changed 7 years ago by stuartm

Component: MythTV - GeneralMythTV - User Interface Library
Milestone: unknown0.25
Priority: majorblocker

See also #9388

comment:10 Changed 7 years ago by beirdo

See also #9547

comment:11 Changed 7 years ago by beirdo

Milestone: 0.25unknown

I'm removing the milestone as it is not clear that this will be fixed with no input from affected users. When we get more input, it can be set at that time.

comment:12 Changed 7 years ago by beirdo

We need either a test case that allows us to reproduce this, or to have someone who is affected to work with us. This is a serious bug, but we are not being able to move forward on it. To the original poster: Is this still happening? Have you tried master (0.25-pre)?

comment:13 Changed 7 years ago by brian@…

I have not seen it in a while. I am also on master now though.

comment:14 Changed 7 years ago by beirdo

Resolution: Unverified
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.