Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9638 closed Bug Report - General (Works for me)

Mythmusic - track time bar not functioning

Reported by: jim.hitch.els@… Owned by: paulh
Priority: minor Milestone: unknown
Component: Plugin - MythMusic Version: 0.24-fixes
Severity: low Keywords: mythmusic player
Cc: Ticket locked: no

Description

In the player ui, the timer bar is not indicating the progress of tracks. Additionally the total time of the track is not available, only the amount of time a track has so far been playing.

Change History (4)

comment:1 Changed 8 years ago by paulh

It's working OK for me in 0.24-fixes.

One possibility is somehow your tracks have got a length of 0.00 in the DB. One way to check is to see what time is reported on the track info screen. At the moment that is only available from the mini-player by pressing INFO. So if you haven't already done so bind a key to the 'Show Music Miniplayer' jump point. Start music playing then back out to the menu opting to continue playing. Then press the 'Show Music Miniplayer' key you have bound to show the mini-player the press INFO to show the track info dialog and note the track length shown there.

Recently stuartm disabled reading the track lengths from id3 tags in master since it seems they are often wrong not sure if that is something to do with it (4e53b234955).

comment:2 Changed 8 years ago by jim.hitch.els@…

Have done what you said and there is no track length shown in the miniplayer, only the amount of time that the track has been playing.

However, I can confirm that tracks are all now seen as 0.00 in length (can do this by going to tracks from 'select music'.

I've always had ID3 tags ignored anyway.

I've tried several tracks and it's the same for each.

This worked before either recent updates from 0.24 or certainly before I moved from 0.23.1 to the present.

comment:3 Changed 8 years ago by paulh

Resolution: Works for me
Status: newclosed

I can't reproduce this in master. Also MythMusic will now correct any track lengths if the played length doesn't match the one stored in the DB.

comment:4 Changed 8 years ago by jim.hitch.els@…

It must be something buggy with my particular database, as I'm using Fixes, but it's still not working for me. Not a big problem, though.

Note: See TracTickets for help on using tickets.