Opened 10 years ago

Closed 10 years ago

#9652 closed Bug Report - General (Fixed)

never ending transcode in mpeg2 recording

Reported by: managementboy@… Owned by:
Priority: minor Milestone: 0.25
Component: MythTV - Mythtranscode Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

after updating to revision 20110308.702d5f7 of trunk from 20110302.6b7ea31 most mpeg2 recordings that need a transcode get stuck in an never ending loop. I had to kill several mythtranscode processes that had been running for hours this morning. Switching back to 20110302.6b7ea31 worked fine. Attached an excerpt from my mythbackend logs right around the time one of the transcodings started.

Attachments (3)

transcode.txt (5.4 KB) - added by managementboy@… 10 years ago.
log output while starting a transcode
log (76.1 KB) - added by Federico <federico.ferri@…> 10 years ago.
version_info (660 bytes) - added by Raymond Wagner 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by managementboy@…

Attachment: transcode.txt added

log output while starting a transcode

comment:1 Changed 10 years ago by zeloise@…

this seems to appears after the commit 649fa85cb41f12860603 (Add support for E-AC3, TrueHD and DTS-HD digital passthrough), 27/02/2011

I hope this helps, zeloise

comment:2 Changed 10 years ago by Federico <federico.ferri@…>

same problem with mythtranscode.

i made a test running mythtranscode from command line. i attach the verbode log.

/usr/local/bin/mythtranscode --mpeg2 --chanid 9122 --starttime 20110320232000 --honorcutlist --outfile /Storage/Group_2/Recordings/9122_20110320232000.mpg.tmp -v all > log

the directory is full of "cnv0.enc","cnv0.enc.yuv","cnv0.enc.yuv.enc".. etc...

my system is:
MythTV Version : v0.25pre-1456-g6c7a2ea MythTV Branch : master Network Protocol : 65 Library API : 0.25.20110310-1 QT Version : 4.6.3 Options compiled in:

linux release use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_hdpvr using_iptv using_ivtv using_libxml2 using_lirc using_mheg using_opengl_video using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_ffmpeg_threads using_live using_mheg using_libxml2

Version 0, edited 10 years ago by Federico <federico.ferri@…> (next)

Changed 10 years ago by Federico <federico.ferri@…>

Attachment: log added

comment:3 Changed 10 years ago by Federico <federico.ferri@…>

For my system this bug is critical, it always happen, so i can't use mythtranscode any more. I will check with 20110302.6b7ea31 version.

Changed 10 years ago by Raymond Wagner

Attachment: version_info added

comment:4 Changed 10 years ago by beirdo

Status: newinfoneeded_new
Version: UnspecifiedTrunk Head

Please try again with a fresh build. I think may have gotten fixed in #9690.

comment:5 Changed 10 years ago by Federico <federico.ferri@…>

New fresh trunk build. Everything works good.
thank you.

comment:6 Changed 10 years ago by beirdo

Milestone: unknown0.25
Resolution: Fixed
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.