Opened 14 years ago

Closed 14 years ago

#967 closed defect (invalid)

Conflict resolution code with many shows appears to break down

Reported by: term-mt1@… Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version: 0.18.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I did a search of existing bugs before filing this, so if I missed one describing this problem, I apologize in advance.

I'm using 0.18.1 across the board. I told myth to record a bunch of shows/movies/etc., and then starting marking anything falling into specific time windows "don't record". I started doing this with the web interface, and after roughly a dozen such changes, changes started failing. If I brought up the show's details, marked it as don't record this instance, and hit submit, it'd claim success, but in some of the cases, the Notes: section would _still_ incidate myth was going to tape it even though the updated details page indicated it was instructed to skip it. Reloading scheduled_recordings.php or looking at mythfrontend reported this as well. I also tried performing such changes via mythfrontend, with no better luck.

It doesn't appear to be a race condition, but oddly, I waited several hours and removed a few of the offending programs entirely (cancelled) and put them back, and it's cooperated better, but still not right. Very strangely, it also re-enabled taping of a show it had previously realized was already taped just 2 nights ago.

Hopefully this won't make a difference, but this is running over current Gentoo, 2.6 kernel, WinTV 250 and ivtv driver (which have been stable for a long, long time). I did upgrade Gentoo (including mysql to 4.1.14, but not mythtv) before trying this.. it's been a long time since I've tried doing such taping, and I don't remember having much better success, so it's possible the bug was always there.

Workarounds (including what I could muck with in the sql tables) would be great. I'm still trying to make this work. :)

Change History (1)

comment:1 Changed 14 years ago by bjm <bjm@…>

Resolution: invalid
Status: newclosed

This is neither a patch nor a reproducible test case. Trac is not a discussion forum for asking about behavior you don't understand. Post questions to the mailing lists.

Note: See TracTickets for help on using tickets.