Opened 9 years ago

Closed 9 years ago

#9681 closed Bug Report - Crash (Invalid)

Lock-up of Myth-frontend while playing recorded TV

Reported by: garry.leach@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am basically an end-user, so my way of expressing things may not be very technical.

On the evenings of both 20/03/2011 & 21/03/11, the recording (different for each night) that I was watching stopped playing, but left the image on the screen (similar to pause). The keyboard & mouse were also locked-up. I left it for 30 minutes, but nothing changed. The only way to shut the computer down was by holding the power button for about 6 seconds (I expect that reset would also have worked).

On both evenings, & prior to the failure, I had watched several recordings without incident.

I don't know how to reproduce the problem, other than keep watching recordings until some factor causes one to lock-up.

I recently upgraded to Mythbuntu 10.10, then used the PPA system to upgrade to Myth 0.24; I have downloaded all proposed updates since then.

Up until 11/03/2011, I was using Mythbuntu 9.10. This was quite stable for over 12 months usage (as were previous versions). I had had problems with Ubuntu 10.04, so didn't want to go to Mythbuntu 10.04.

However, I wanted to have the better shut-down screen (part of Consolekit?), & I hoped that there may be some Myth improvements.

On 12/03/2011, I upgraded to Mythbuntu 10.04. There were lots of problems with this, including that I could not delete recordings made on that day (apart from using file manager). Another problem: WatchTV crashed the Myth fontend back to the desktop.

So on 13/03/2011, I upgraded to 10.10. This was not much better.

So I researched the PPA facility & upgraded to stable Myth 0.24. While doing this, I noticed (somewhere) a button to do something to the database, so I clicked on that.

Whether it was the installation process for 0.24, or the database review, the system now worked as it should.

However, I didn't have the logout screen that I wanted (& had seen on a live CD of 10.10). On 19/03/11, a friend helped me fix the logout screen (ticking the Prompt on Logout field on the Session & Start-up screen).

Since then, Myth frontend does not start automatically. Should it be listed in Session & Start-up?

I have copied an extract of the backend log file (covering the 30 minutes on 21/03/2011 when the screen locked-up) & attached that below. (There was no frontend log file).

My hardware is 2.5 years old, with more than adequate "capacity" to handle Myth; the PC is dedicated to MythTV & is not used for anything else.

Thanks in advance, Garry.

Attachments (1)

MythBE log 110321 22-00 locked system (5.9 KB) - added by garry.leach@… 9 years ago.
Extract from Myth backend log file, covering the problem time on 21/03/2011.

Download all attachments as: .zip

Change History (2)

comment:1 Changed 9 years ago by robertm

Resolution: Invalid
Status: newclosed

Hi Garry,

Thanks for the report. Everything I am reading here appears to be issues with the stability of your system and distro itself, rather than MythTV. MythTV, as a high level application, is generally unable to completely hard-lock your system as you describe. When you see a lock of the keyboard and mouse, you're dealing with a hung system, not a hung MythTV.

Regarding your other questions about automatic startup, login and logout screens, etc., those are all questions for your distribution provider (in this case, MythBuntu?). It's important to understand the distinction between a MythTV distro (Mythbuntu) and MythTV itself, which is essentially a suite of applications which are unable to hang your system, crash the window.

Your inability you delete a recording sounds like a permissions issue, which is again related to the underlying OS and permissions, not MythTV itself.

You may wish to ask some of these questions of your distro maintainers, or on our users list.

Good luck resolving the issues you have found here.

Changed 9 years ago by garry.leach@…

Extract from Myth backend log file, covering the problem time on 21/03/2011.

Note: See TracTickets for help on using tickets.