Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9683 closed Bug Report - General (Invalid)

Multi-tuner setup will not record more than 1 show

Reported by: junk No Spam <junk_no_spam@…> Owned by:
Priority: minor Milestone: 0.24.1
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Raymond Wagner)

My setup is 2 "HDHomeRun SiliconDust? dual" network tuners on ip 169.254.1.26 and 169.254.1.27 running on Mandriva Linux 2010.2 using SchedulesDirect? for listings. Works with no problem on version 0.23

Installed Mandriva Linux 2011.0 on a Test system. Adding mythtv packages installs version 0.24. As a Oh By the Way, it forced me to install 0.24 on my "Production" back end and my "Production" Front end systems. :( I talked with $DEITY for a few minutes about that,

Stopped mythtvbackend, dropped the myth database, created it.

Ran mythtv-setup and answered OK to upgrade prompts. Exited mythtv-setup, ran mythtv-setup again and proceeded to complete the install/setup. Started mythtvbackend, ran mythfilldatabase.

Deleted ~.mythtv/* on front end system, and ran mythtvfrontend

First problem: mythtv-setup creates 8 tuners when I defined 4 tuners. :-( Went back, deleted all tuners, created 4 again and still wound up with 8.

Second problem: While recording one show and running Watch TV, it used the same tuner and killed the recording. Looking at mythtv tuner info, it showed tuner 1 recording. Led on tuner hardware was not lit indicating not in use.

Third problem: Scheduled 4 recordings at next half hour. One led lit on each tuner instead of two lit on each.

mythtv tuner status showed 4 tuners recording. Getting into the media library showed no picture but had green circle for 4 recordings but when selecting each, gave no file found.

Using phpmyadmin, I noticed inputgroup, capturecard, and cardinput had 8 rows instead of 4. I noticed the cardinput.externalcommand field not NULL, so I used it to delete the bogus rows.

DELETE FROM inputgroup WHERE inputgroup.cardinputid = ( SELECT cardinputid FROM cardinput WHERE inputgroup.cardinputid = cardinput.cardinputid AND cardinput.externalcommand IS NOT NULL) ;

DELETE FROM capturecard WHERE capturecard.cardid = ( SELECT cardid FROM cardinput WHERE capturecard.cardid = cardinput.cardid AND cardinput.externalcommand IS NOT NULL) ;

DELETE FROM cardinput WHERE cardinput.externalcommand IS NOT NULL ;

That left me with tuners 1, 3, 5 and 7.

Did the tv test again and it did pick the other tuner box and did not kill the recording. Did the 4 recording test again and only 1 led on each tuner box lit up and all recordings failed.

FRAP, three days shot to hell. Stopped mythtvbackend and deleted ~.mythtv/* on all systems. Wiped/clean install of operating systems on both Production back and front ends, then installed 0.23.

$ mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version   : 0.24-27162.3
MythTV Branch    : exported
Network Protocol : 63
Library API      : 0.24.20101028-1
QT Version       : 4.7.1

Change History (2)

comment:1 Changed 9 years ago by robertm

Resolution: Invalid
Status: newclosed

Creating 8 encoders from 4 physical tuners with the HDHomeRun is correct. The second is a virtual tuner for purposes of multirec.

The rest of this is a dupe of #9247, which can be gotten around by configuring your HDHomeruns as autodetect rather than by IP.

In the future, rather than cramming as many perceived bugs into one ticket as possible, it would be helpful to have one ticket per suspected issue.

If you need help working around #9247, please start on the -users mailing list.

comment:2 Changed 9 years ago by Raymond Wagner

Description: modified (diff)
Note: See TracTickets for help on using tickets.