Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9688 closed Bug Report - General (fixed)

Mythvideo crashes between 6b7ea31 and 0b1f9d2

Reported by: yiannividalis@… Owned by: jyavenard
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by wagnerrp)

I updated all three frontends. The main frontend (opensuse 11.2, digital audio) which is also the MB crashes upon starting certain video files. The other two frontends (opensuse 11.3, analog audio) don't have this problem.
AVIs with xvid video and mp3 audio play fine.
Most mkvs with avc video and AC3 audio crash.
mkvs with avc video and AAC audio play fine.

A film that crashes has:

Format                           : Matroska
File size                        : 2.74 GiB
Duration                         : 2h 31mn
Overall bit rate                 : 2 589 Kbps
Writing application              : HandBrake rev2965

Video
ID                               : 1
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L3.0
Format settings, CABAC           : Yes
Format settings, ReFrames        : 3 frames
Muxing mode                      : Container profile=Unknown@3.0
Codec ID                         : V_MPEG4/ISO/AVC
Duration                         : 2h 31mn
Bit rate                         : 2 200 Kbps
Width                            : 720 pixels
Height                           : 432 pixels
Display aspect ratio             : 2.35:1
Frame rate                       : 25.000 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.283
Stream size                      : 2.28 GiB (83%)
Writing library                  : x264 core 79
Encoding settings                : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=9 / psy=1 / psy_rd=1,0:0,0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=6 / nr=0 / decimate=1 / mbaff=0 / constrained_intra=0 / bframes=6 / b_pyramid=0 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / wpredp=2 / keyint=250 / keyint_min=25 / scenecut=40 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=2200 / ratetol=1,0 / qcomp=0,60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20,0 / qblur=0,5 / ip_ratio=1,40 / aq=1:1,00
Color primaries                  : BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170M
Transfer characteristics         : BT.709-5, BT.1361
Matrix coefficients              : BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170M

Audio
ID                               : 2
Format                           : AC-3
Format/Info                      : Audio Coding 3
Mode extension                   : CM (complete main)
Codec ID                         : A_AC3
Duration                         : 2h 31mn
Bit rate mode                    : Constant
Bit rate                         : 384 Kbps
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Side: L R, LFE
Sampling rate                    : 48.0 KHz
Bit depth                        : 16 bits
Stream size                      : 416 MiB (15%)
Language                         : English

A film that plays ok has:

Format                           : Matroska
File size                        : 190 MiB
Duration                         : 23mn 5s
Overall bit rate                 : 1 147 Kbps
Writing application              : HandBrake rev2965

Video
ID                               : 1
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L3.0
Format settings, CABAC           : Yes
Format settings, ReFrames        : 3 frames
Muxing mode                      : Container profile=Unknown@3.0
Codec ID                         : V_MPEG4/ISO/AVC
Duration                         : 23mn 5s
Bit rate                         : 950 Kbps
Width                            : 720 pixels
Height                           : 576 pixels
Display aspect ratio             : 4:3
Frame rate                       : 24.950 fps
Standard                         : PAL
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.092
Stream size                      : 154 MiB (81%)
Writing library                  : x264 core 79
Encoding settings                : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=9 / psy=1 / psy_rd=1,0:0,0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=6 / nr=0 / decimate=1 / mbaff=0 / constrained_intra=0 / bframes=6 / b_pyramid=0 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / wpredp=2 / keyint=250 / keyint_min=25 / scenecut=40 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=950 / ratetol=1,0 / qcomp=0,60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20,0 / qblur=0,5 / ip_ratio=1,40 / aq=1:1,00
Color primaries                  : BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170M
Transfer characteristics         : BT.709-5, BT.1361
Matrix coefficients              : BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170M

Audio
ID                               : 2
Format                           : AC-3
Format/Info                      : Audio Coding 3
Format profile                   : Dolby Digital
Mode extension                   : CM (complete main)
Codec ID                         : A_AC3
Duration                         : 23mn 5s
Bit rate mode                    : Constant
Bit rate                         : 192 Kbps
Channel(s)                       : 2 channels
Channel positions                : Front: L R
Sampling rate                    : 48.0 KHz
Bit depth                        : 16 bits
Stream size                      : 31.7 MiB (17%)
Language                         : Greek

The final lines of log output of mythfrontend -v all is:

2011-03-24 18:13:02.730 MythUIHelper: NOT IN RAM CACHE, Adding, and adding to size :images-osd_overlay.png--975x149.png: :581100:
2011-03-24 18:13:02.730 MythUIHelper: MythUIHelper::CacheImage : Cache Count = :235: size :11379676:
2011-03-24 18:13:02.730 MythUIImage(0x7fef1cd451c0): LoadImage found in cache :images-osd_overlay.png--975x149.png: RefCount = 2
2011-03-24 18:13:02.730 MythUIImage(0x7fef1cd4a580): LoadImage(images/osd_overlay.png) Object entry_overlay
2011-03-24 18:13:02.730 MythUIHelper: LoadCacheImage(images/osd_overlay.png,images-osd_overlay.png--975x149.png)
2011-03-24 18:13:02.730 MythUIImage(0x7fef1cd4a580): LoadImage found in cache :images-osd_overlay.png--975x149.png: RefCount = 3
2011-03-24 18:13:02.731 OSD: Loaded window osd_program_editor
2011-03-24 18:13:02.732 OSD: Loaded OSD: size 1920x1080 offset 0+0
2011-03-24 18:13:02.733 MSqlQuery::exec(DBManager0) SELECT data FROM settings WHERE value = 'osdcc708textzoom' AND hostname = 'al2kpro' <<<< Returns 1 row(s)
2011-03-24 18:13:02.734 MSqlQuery::next(DBManager0) Result: "data = 100"
2011-03-24 18:13:02.734 Resetting carousel
2011-03-24 18:13:02.735 Player(0): ClearAfterSeek(0)
2011-03-24 18:13:02.735 Player(0): A/V sync reset
2011-03-24 18:13:02.735 AO: OutputAudioLoop: Play Event
2011-03-24 18:13:02.736 VDP: GetFilteredDeint() : vdpau -> 'vdpauadvanceddoublerate'
2011-03-24 18:13:02.737 VidOutVDPAU: Enabled deinterlacing.
2011-03-24 18:13:02.737 VSYNC: DRMVideoSync: Could not open device /dev/dri/card0, Îεν Ï
ÏάÏÏει Ï
           έÏ
              οιο αÏÏείο ή καÏ
                                        άλογοÏ
2011-03-24 18:13:02.738 VSYNC: RTCVideoSync: Could not set RTC frequency, ÎÏνηÏη ÏÏÏÏβαÏηÏ.
2011-03-24 18:13:02.739 Player(0): Video timing method: USleep with busy wait
2011-03-24 18:13:02.739 Player(0): Display Refresh Rate: 59.999 Video Frame Rate: 24.998
2011-03-24 18:13:02.739 Player(0): SetFrameInterval ps:1 scan:1
2011-03-24 18:13:02.749 VidOutVDPAU: Created VDPAU decoder (3 ref frames)
2011-03-24 18:13:02.750 [h264_vdpau @ 0x7fef3dbf94c0]no picture
2011-03-24 18:13:02.750 AFD: video packet timestamps reordered 0 pts 80 dts 0 (reordered active)
2011-03-24 18:13:02.750 AFD: video timecode 0 0 40 0 fixup
2011-03-24 18:13:02.750 [spdif @ 0x7fef3e40f960]type=1 len=1536 pkt_offset=6144
2011-03-24 18:13:02.750 AO: AddData frames=1536, bytes=6144, used=1, free=3071999, timecode=64 needsupmix=0


Driver is nVidia 256.53.

Please let me know if you want me to provide any more information.

Attachments (4)

version_info (676 bytes) - added by wagnerrp 3 years ago.
gdb.txt.gz (12.8 KB) - added by yiannividalis@… 3 years ago.
debug information as requested
gdb.txt (125.6 KB) - added by yiannividalis@… 3 years ago.
newer gdb.txt
frontend.log (20.7 KB) - added by yiannividalis@… 3 years ago.
As requested, the frontend.log

Download all attachments as: .zip

Change History (20)

comment:1 Changed 3 years ago by robertm

  • Component changed from Plugin - MythVideo to MythTV - Video Playback
  • Status changed from new to infoneeded_new
  • Version changed from Unspecified to Trunk Head

MythVideo? is a metadata manager, not a video player. Also, we need a backtrace of your crash.

comment:2 Changed 3 years ago by wagnerrp

  • Description modified (diff)

Changed 3 years ago by wagnerrp

comment:3 Changed 3 years ago by yiannividalis@…

Thanks for the clarification.

How can I produce a backtrace?

comment:4 Changed 3 years ago by robertm

You can follow the instructions here:

http://www.mythtv.org/wiki/Debugging

or per section 22.2 of our manual.

Changed 3 years ago by yiannividalis@…

debug information as requested

comment:5 Changed 3 years ago by yiannividalis@…

The commit that breaks my system is d019ea. It works fine up and including d392ee.

comment:6 Changed 3 years ago by robertm

  • Owner changed from robertm to jyavenard

comment:7 Changed 3 years ago by jyavenard

SHA: d019ea is a merge from master to another branch.
How could it work in SHA: d392ee but not SHA: d019ea if using master makes no sense whatsoever. You must have made a mistake somewhere when tracking the *"bug" as no code in master is modified between those two commits unless you do not use master.

Looking at the backtrace, you have an non-updated/recompiled libmyth (the number of arguments provided to AddData? doesn't match the current code).

Make sure you run make distclean ; then re-do a configure.

This sounds more like a compilation issue than anything else.

Typically what would happen if you ran different version of libmythtv and libmyth

comment:8 Changed 3 years ago by yiannividalis@…

Further to jy's remarks, I removed /usr/share/mythtv, /usr/include/mythtv, /usr/lib/mythtv.

I searched for any *myth* reference and deleted it, too.

I cloned the master git repo again, compiled a debug version and installed again. The problem remains.

If I run git checkout d392ee, the resulting installation plays videos normally.

Anything above that checkpoint and the specific videos don't start. I am including a newer gdb.txt just in case anything is different. I don't think there is any more garbage left (although before this cleanup I found /usr/lib/libmythtv-0.23.so and libmythpostproc-0.23.so )

I would appreciate any input you may have. If you still think this is *my* problem and not a bug, let me know and I will write to the users' list. I know this is not a support forum.

Thanks again,

Yianni

Changed 3 years ago by yiannividalis@…

newer gdb.txt

comment:9 Changed 3 years ago by jyavenard

There is still the same issue, that two function calls do not get the same argument between the caller and the callee. This will happen as the API changed recently (AddData? takes a fourth argument). libmythtv calls add data with 4 arguments, yet adddata expects 3.

I would check again that you have run make distclean followed by configure again and that there aren't old libmyth*.so hanging in the ldconfig path.

The crash occur is due to the buffer provided to toFloat16 not being 16 bytes aligned, which isn't possible as that buffer is allocated to be 16 bytes aligned (allocated using av_malloc)

comment:10 Changed 3 years ago by jyavenard

Just had a thought: can you provide the log generated by mythfrontend with -v audio,playback and play a file that crash. And post the entire output

Changed 3 years ago by yiannividalis@…

As requested, the frontend.log

comment:11 Changed 3 years ago by jyavenard

What are your audio settings? (all of them)
Did you enable software volume control ?

comment:12 Changed 3 years ago by Jean-Yves Avenard

  • Milestone changed from unknown to 0.25
  • Resolution set to fixed
  • Status changed from infoneeded_new to closed

Disable passthrough only if using the software volume controller.

If using another type of mixer; as it will be ignored we can passthrough. Alternatively, if Myth Volume control was checked, but nothing else was configured; it could have resulted in a bug (try to passthrough, but would enable audio processing).

Fixes #9688

Changeset: 9499674e4eec1c6bdde1da12c013e5edd52bb8ed

comment:13 Changed 3 years ago by yiannividalis@…

Sorry for the delayed response:
My sound settings are:
Device: Alsa:iec958:CARD:NVidia,DEV=0

DD=Yes, DTS=Yes, E-AC3=No, TRUE HD=No, DTS-HD=No

Speaker configuration: 5.1

Upconvert Stereo to 5.1 Surround: Yes

Upmix Quality: Best

Advanced Audio Settings

Override SRC Quality=No
Force 48kHz=Yes, SPDIF 48k rate override=No

Separate Digital Audio Device=No

HBR Passthrough Support=Yes

Mixer:
Use Internal Volume Controls=Yes

Mixer Device=software
Mixer Controls=Master

I have been using these settings for quite a while now without a problem.

I am now at the 52ac546 commit and the problem goes away only if I change the mixer device to anything but software. With software it crashes still.

So, for my specific configuration it hasn't been fixed.

Has the audio configuration changed in such a way that I can no longer use the software mixer? It's not that big a deal but it's some loss of functionality (another remote instead of just the rf keyboard).

Thanks for all your efforts, again.

comment:14 Changed 3 years ago by jyavenard

Can you provide the following info:
*mythfrontend --version
*Another backtrace
*try playing the same file with mythavtest -v audio,playback and post the full output

comment:16 Changed 3 years ago by yiannividalis@…

Thanks, JY.

I am now at e5f39e9, using software mixer and the problem has gone away!

Thanks for all your trouble!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.