Opened 8 years ago

Closed 5 years ago

#9710 closed Bug Report - General (Works for me)

Long delays and random noises when trying to start watching recording

Reported by: Marc Randolph <mrand@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

These logs are all I have, so if it is not good enough, please close the ticket. This is a combined FE + BE. Backend starting recording Castle on a HDHR at 21:00. Frontend was idle.

2011-04-04 21:34:43.204: I selected LiveTV, and it eventually launched. I exited.

2011-04-04 21:35:05.033, I went back to the recordings list and selected Castle, which was still recording. Very long delay again (over 20 seconds I think), some random noises which did not impress the wife, and then eventually it dumped me back into the recordings screen.

2011-04-04 21:35:29.989 I reselected the recording. After waiting another very long delay (~15 seconds), we were finally watching the recording. During the delay, there were, again, some random sounds.

Also, completely unrelated, in looking over the logs, I noticed this:

2011-04-04 22:00:33.625 TV: Attempting to change from WatchingRecording to WatchingPreRecorded
2011-04-04 22:00:33.625 TV: Changing from WatchingRecording to WatchingPreRecorded

The time stamp corresponds with when the recording ended.

Attachments (2)

mythfrontend.log.gz (23.2 KB) - added by Marc Randolph <mrand@…> 8 years ago.
mythbackend.log.gz (30.9 KB) - added by Marc Randolph <mrand@…> 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Marc Randolph <mrand@…>

Attachment: mythfrontend.log.gz added

Changed 8 years ago by Marc Randolph <mrand@…>

Attachment: mythbackend.log.gz added

comment:1 Changed 8 years ago by Marc Randolph <mrand@…>

I should probably note that this is a 2.2 GHz core2duo with a GT430 with VDPAU enabled. These longer delays seem to be fairly new, although I can't say with any certainty over which time frame they have appeared.

comment:2 Changed 8 years ago by andyandtaya@…

I can confirm this issue on an upgrade from 0.23 to 0.24 running an nvidia GT210. Seomtimes there are long delays when watching TV or a recording, but not always. There is nothing in the backend or frontend logs to indicate why. I was initially of the impression it was caused by audio buffering issues due to too small a value in /proc/asound/card0/pcm0p/sub0/prealloc But this fix only seems temporary

comment:3 Changed 6 years ago by stuartm

Status: newinfoneeded_new

Marc can you still reproduce this with a later release, say 0.26?

comment:4 Changed 5 years ago by sphery

Resolution: Works for me
Status: infoneeded_newclosed

Originally reported against 0.24-fixes. No info on whether this still occurs with 0.26-fixes (or now even 0.27-fixes) has been provided in 7 months.

Note: See TracTickets for help on using tickets.