Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

#9715 closed Bug Report - General (Invalid)

Mythtranscode stalls "converting frame #14 from P to I"

Reported by: Phil <pmagnone@…> Owned by: beirdo
Priority: minor Milestone: unknown
Component: MythTV - Mythtranscode Version: Master Head
Severity: medium Keywords: mythtranscode, hang, stall, transcode, cutlist
Cc: Ticket locked: no

Description

At first, I thought this was the same as Ticket #2077, but I never actually get the "deadlock detected" error. Instead, mythtranscode will just stall while transcoding a recording anywhere between 80-99% completion. If I run mythbackend from terminal, the last output it gives me is "Converting frame #14 from P to I" or something similar (different frame, and sometimes B instead of P). This happens on multiple recordings with cutlists.

I believe this began somewhere around mid-March with my latest "git pull", but I can't be positive on the exact date.

I've attached the output of "mythbackend -v all > myth.log". There's an awful lot of output there, so if you can tell me what to specify for verbose, I can shrink that down for you. For this particular log file, the transcode job stalled at 97.3%.

Please let me know what additional information I can provide.

Attachments (0)

Change History (7)

comment:1 Changed 3 years ago by Phil <pmagnone@…>

Sorry, the file was WAY too large to add as an attachment, so until I can be more specific with the verbose options to get a smaller file, here's a link to the file on my Dropbox:

http://dl.dropbox.com/u/162975/myth.log

comment:2 Changed 3 years ago by beirdo

  • Owner set to beirdo
  • Status changed from new to assigned

What type of file are you trying to transcode from and to?

comment:3 Changed 3 years ago by beirdo

  • Status changed from assigned to infoneeded

I may need an example file to test with as well (cut to 100MB or so if possible, and if it shows the problem)

comment:4 Changed 3 years ago by Phil <pmagnone@…>

I'm doing a lossless transcode of an MPEG-2 TV recording (720P w/ AC-3 audio) just to snip the commercial breaks, at which point I usually use Handbrake if I want to archive the video with better compression. I've tried transcoding multiple shows from multiple channels, but I still get the same result. Each time it stalls at 80-90% and "mythtranscode" shows ~100% CPU usage in "top", and I have to kill the process manually.

Here's a 60 second, 99MB clip from near the end of one of those recordings (used "ffmpeg -vcodec copy -acodec copy -ss 00:31:45 -t 60 -i [input].mpg [output].mpg").

http://dl.dropbox.com/u/162975/test.mpg

While navigating my recordings directory, I noticed that there was a *.mpg.tmp file for at least some of the shows I tried to transcode. Near as I can tell, the transcode jobs actually finished (the files play back without any issue), but the mythtranscode process never exited correctly.

comment:5 Changed 3 years ago by beirdo

  • Status changed from infoneeded to assigned

comment:6 Changed 3 years ago by beirdo

  • Status changed from assigned to infoneeded

If this still occurs, could you please attach gdb to the process while it is using 100% CPU and get a full backtrace of all threads (on mythtranscode)? I think it may just be a case of unclean shutdown, but I'm not sure.

comment:7 Changed 3 years ago by robertm

  • Resolution set to Invalid
  • Status changed from infoneeded to closed

No response.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.