Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9718 closed Bug Report - General (Unverified)

Interactive TV (teletext) starts in wrong resolution

Reported by: keith.allcock@… Owned by: markk
Priority: minor Milestone:
Component: MythTV - Video/OSD Rendering Version: 0.24-fixes
Severity: medium Keywords: teletext mythtv playback
Cc: Ticket locked: no

Description

This is most noticeable in the UK when watching sports events on the BBC as the "PRESS RED" shows in the top centre instead of top right. Playback should be 1238:690, but the overlay starts at 720:576. After pressing W until the OFF option will reset the overlay correctly and the PRESS RED message will move to the correct position.

Change History (6)

comment:1 Changed 8 years ago by Raymond Wagner

Component: MythTV - GeneralMythTV - Video/OSD Rendering
Milestone: 0.24.1
Owner: set to markk
Status: newassigned

Are you using the Xv, OpenGL, or VDPAU video renderer?

comment:2 Changed 8 years ago by keith.allcock@…

I am using VDPAU.

It may also be that this is on recordings and not live TV. Yesterday I started to watch the Grand Prix recording and had this issue, but then switched to live TV and didnt have the issue.

comment:3 Changed 8 years ago by markk

Milestone: 0.24.2

I can't currently test this as MHEG support was broken in the last ffmpeg sync. I'll work on a fix as soon as I can reproduce again.

comment:4 Changed 8 years ago by markk

Status: assignedaccepted

comment:5 Changed 8 years ago by markk

Resolution: Unverified
Status: acceptedclosed

Tested on master with both live tv and recordings and I can't reproduce. It may be that the specific issue (sounds like a timing/sequence issue on playback startup) was fixed in master a while back or there is an additional playback setting that is disrupting rendering that I haven't tested. It is odd however that the same issue hasn't been reported elsewhere.

If this is still an problem, please re-open and attach the full output of mythfrontend -v playback and note any non-standard playback settings you are using.

comment:6 Changed 8 years ago by stuartm

Milestone: 0.24.2

Milestone 0.24.2 deleted

Note: See TracTickets for help on using tickets.