Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9724 closed Bug Report - General (fixed)

Internet Video (blip.tv) broken in 0.24

Reported by: emunson@… Owned by:
Priority: trivial Milestone: 0.24.1
Component: Plugin - MythNetvision Version: 0.24-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

Before upgrading from 0.23 I was able to both search blip.tv and play the results, and I was able to subscribe to and watch an RSS feed from the same. Now that I have upgraded to 0.24 from the mythbuntu repository I cannot do search or watch videos in my RSS feed.

When I select Search Internet Videos, input "day9", and select blip.tv, nothing happens. The interface sits there but is not hung. Searching from youtube seems to work.

I can subscribe to the day9 RSS feed, and when I update it I see new episodes. However, when I select an episode nothing happens. Again, the interface is not hung, it responds to input, but I cannot play any selected episodes.

I have reported this to the Mythbuntu project, but they have been unresponsive for 2 weeks.

Attachments (0)

Change History (10)

comment:1 Changed 3 years ago by robertm

  • Resolution set to Invalid
  • Status changed from new to closed

curl http://www.blip.tv/rss?search=day9

That's an API search according to their API reference:

http://wiki.blip.tv/index.php/RSS_Output_Format

MythNetvision? isn't broken, blip.tv is. The grabber should probably be removed if the APi doesn't resolve itself in the near future.

comment:2 Changed 3 years ago by Github

Internet Content: Correct Blip.tv API URL.

Seems that they changed things up, and I had misread the API URL. Thanks to Kenni Lund for seeing where I had gone wrong. Refs #9724.

Changeset: d7550bfbf245e4e61fcf00a1ad16375d404c0944

comment:3 Changed 3 years ago by Github

  • Milestone changed from unknown to 0.24.1
  • Resolution changed from Invalid to fixed

Internet Content: Correct Blip.tv API URL.

Seems that they changed things up, and I had misread the API URL. Thanks to Kenni Lund for seeing where I had gone wrong. Fixes #9724.

Changeset: 1cfcb2b7eecacce7e1ecc8542bff67dfd3f0139f

comment:4 Changed 3 years ago by emunson@…

  • Resolution fixed deleted
  • Status changed from closed to new

This fixes half the problem. With this patch applied I can search blip tv and watch the resulting videos. However, I still cannot watch anything from my RSS feed.

comment:5 Changed 3 years ago by robertm

  • Component changed from MythTV - General to Plugin - MythNetvision
  • Priority changed from major to trivial
  • Severity changed from medium to low
  • Status changed from new to infoneeded_new

We don't make claims to be a universal RSS parser. If you want it fixed you need to produce RSS output, database dumps, etc.

And please read the ticket howto-- this is hardly a major problem, nor are you intended to set that value.

comment:6 Changed 3 years ago by emunson@…

Sorry for messing with the Priority field, I will RTFM next time.

I set the priority as high because this is a regression, not a new feature. All of this _used_ to work in 0.23 but doesn't any longer.

I am happy to provide any information you need to help diagnose the problem, how can I provide you with the things you have requested?

comment:7 Changed 3 years ago by robertm

Provide a URL to the RSS feed, please.

comment:8 Changed 3 years ago by emunson@…

comment:9 Changed 3 years ago by Github

  • Resolution set to fixed
  • Status changed from infoneeded_new to closed

RSS Parsing: Check player tags to make sure they don't have child elements.

This works around some very odd RSS feeds produced by Blip.tv, which inline a bunch of of HTML instead of using attributes as the Media RSS specification specifies:

Reference: http://video.search.yahoo.com/mrss

"Allows the media object to be accessed through a web browser media player console. This element is required only if a direct media url attribute is not specified in the <media:content> element. It has 1 required attribute, and 2 optional attributes.

\<media:player url=\"http://www.foo.com/player?id=1111\" height=\"200\" width="400" /\>

url is the url of the player console that plays the media. It is a required attribute.

height is the height of the browser window that the url should be opened in. It is an optional attribute.

width is the width of the browser window that the url should be opened in. It is an optional attribute."

So, basically, we work around the violation of the spec by checking for child elements.

Fixes #9724.

Changeset: f6e282f4cd95de787448ee32281cc0c20caafc5d

comment:10 Changed 3 years ago by emunson@…

Thanks, this fixed it for me.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.