Opened 9 years ago

Closed 9 years ago

#9758 closed Bug Report - General (Duplicate)

MythTV Backend Setup produces the message "ERROR, COMPILE WITH V4L SUPPORT TO QUERY AUDIO INPUTS" while adding an HDPVR to capture cards

Reported by: ddurdin@… Owned by:
Priority: blocker Milestone: 0.24.1
Component: MythTV - General Version: 0.24
Severity: medium Keywords: hdpvr
Cc: ddurdin@… Ticket locked: no

Description

After upgrading to Ubuntu 11.04 and installing MythTV 0.24 I tried to run MythTV Backend Setup. While in the "Capture Card" section and selecting "H.264 Encoder Card(HD-PVR)" the message "ERROR, COMPILE WITH V4L SUPPORT TO QUERY AUDIO INPUTS" is seen in the audio input options area.

From syslog:

May 1 12:18:37 mythserver kernel: [ 9.599510] hdpvr 1-6:1.0: firmware version 0x15 dated Jun 17 2010 09:26:53 May 1 12:18:37 mythserver kernel: [ 9.786212] hdpvr 1-6:1.0: device now attached to video0 May 1 12:18:37 mythserver kernel: [ 9.786239] usbcore: registered new interface driver hdpvr

The hdpvr module is active: hdpvr 32310 0 v4l2_common 16490 1 hdpvr videodev 96656 2 hdpvr,v4l2_common

And this produces a playable file:

cat /dev/video0 > test.ts

Change History (3)

comment:1 Changed 9 years ago by robertm

Resolution: Invalid
Status: newclosed

Then you should compile MythTV with v4l support. This is not a bug, it's a compilation issue (likely related to the fact that 11.04's kernel doesn't support v4l1 which mythTV still requires).

comment:2 Changed 9 years ago by sahendrickson@…

Resolution: Invalid
Status: closednew

This is true for the Myth PPA release. I could download and compile Myth myself, but moved to the PPA release to avoid doing so. Any chance that the PPA release could be modified to have this flag?

http://www.ubuntuupdates.org/ppas/69

comment:3 Changed 9 years ago by danielk

Resolution: Duplicate
Status: newclosed

Dup of #9595. 11.04 is using a kernel which MythTV doesn't yet support.

Note: See TracTickets for help on using tickets.