Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9760 closed Bug Report - General (Invalid)

NoTrans: SQL Error: Unknown column 'future' in 'where clause' [#1054]!!

Reported by: dclemen@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

file: /usr/share/mythtv/mythweb/classes/Database.php line: 322

class: Database

function: query

type: -> args: Array

(

[0] => SELECT COUNT(*) FROM oldrecorded WHERE future = 0 [1] => Array ( )

Change History (3)

comment:1 Changed 9 years ago by Raymond Wagner

Resolution: Invalid
Status: newclosed

You are attempting to run a version of MythWeb too new for your database. This is a schema mismatch.

comment:2 Changed 9 years ago by tom-mythtv@…

I'm getting the same error and ought to have an up-to-date database (using the debian-multimedia packages for sid, and have mythtv-database installed). The backend and frontends seem to work fine, it's just mythweb which is not working since I upgraded to version 0.24+fixes20110426.

Any ideas how to fix it? If I need to update the schema, how is this done? (I had assumed it was done automatically, as I've not needed to do it before).

comment:3 Changed 9 years ago by sphery

Ticket locked: set

This is caused by using MythWeb from unstable/master against a MythTV 0.24 backend/database. It seems there's a problem with the Debian packages that results in these incompatible versions being installed.

Please direct all further questions to the mythtv-users list or, in this case (since it's a Debian packaging problem), you may have better luck with a Debian-/packaging-specific mailing list or forum.

Note: See TracTickets for help on using tickets.