Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#978 closed defect (wontfix)

Browse mode doesn't list all available channels in LiveTV

Reported by: tommi@… Owned by: cpinkham
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have "2" (pvr-500) capture cards, /dev/video0 and /dev/video1.

/dev/video0 has channels available on Tuner and on Composite 0 /dev/video1 has only Tuner channels available

Once in a while I start watching LiveTV I go to my second tuner (video1) since there is a recording taking place on the main tuner. I only have access to my Tuner channels at this time (normal). But once the main Tuner stops recording I still do not have access to my Composite 0 channels.

Reproducable:

  1. Have both cards in non recording mode
  2. Go to LiveTV
  3. Hit "Y" to switch to the second card
  4. Browse mode will only show channels which are valid for that card.

Change History (4)

comment:1 Changed 14 years ago by Isaac Richards

Milestone: unknown0.20
Owner: changed from Isaac Richards to cpinkham

Chris, you can decide if we should do this or not. Personally, I think just displaying channels on the current card is fine for browse mode, since it's easy to switch to other cards.

comment:2 Changed 14 years ago by cpinkham

Resolution: wontfix
Status: newclosed

I agree, otherwise we need to code a bunch of logic to figure out what channels are available based on what tuners are not in use, etc.. It's much easier to just say it's only for the current card rather than explaining why channel X shows up sometimes but not others since Card 2 is in use occasionally. The existing functionality should be less confusing to the user.

Closing ticket as 'won't fix'.

comment:3 Changed 14 years ago by tommi@…

Just wondering if I get a sudden urge to start coding, to show all channels configured, in browse mode, but show unavailable channels with "5 - CNN (Unavailable, tuner(s) in use)" maybe a different color also..

comment:4 Changed 14 years ago by cpinkham

For a patch like this to be accepted, there's a lot of behind the scenes coding that would have to be done. This would include things like handling if the user tried to change channels to an unavailable channel or tried to start recording the current program on that channel. You'd have to handle the case where the channel/tuner's status changes while the user is browsing. The Available/Unavailable? status would have to be available via ProgramInfo::ToMap? so theme designers could display this status as they wanted. It would have to be optional as it doesn't make sense to us to have this functionality since if you're gonna do this, you may as well use the EPG. There are probably a few other situations you'd have to handle for these unavailable channels/tuners, so don't think it's as simple as checking to see if it's in use and displaying a message.

Note: See TracTickets for help on using tickets.