Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9812 closed Bug Report - General (Invalid)

Setting max rate to 192000 causes DTS-HD HRA track not to play

Reported by: mark.goodman@… Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Audio Output Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

A patch that fixes the issue is attached.

Attachments (1)

audiooutputbase.patch (759 bytes) - added by mark.goodman@… 8 years ago.
Let DTS-HD HRA tracks play.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by mark.goodman@…

Attachment: audiooutputbase.patch added

Let DTS-HD HRA tracks play.

comment:1 Changed 8 years ago by JYA

Resolution: Invalid
Status: newclosed

this patch isn't necessary nor would it make any differences if system is properly configured case FF_PROFILE_DTS_HD_MA: m_spdifenc->SetMaxHDRate(OutputSettings?(true)->GetMaxHDRate());

GetMaxHDRate() will return 192000 if max rate was set to 192000.

In the advanced audio section; unckeck HBRPassthrough; which will force 192kHz as maximum allowed rate.

If not check; the DTS-HD HRA will be embedded within a DTS-HD MA stream which all amplifier supporting DTS-HD MA will support.

comment:2 Changed 8 years ago by mark.goodman@…

Thank you for taking the time to respond.

With the patch, the rate is set to 768000 and a Denon AVR-3311CI plays the track showing DTS-HD HI RES. Without the patch, the rate is set to 192000 and nothing is heard.

"HBR passthrough support" is checked, and DTS-HD MA tracks play without issue.

comment:3 Changed 8 years ago by JYA

I think you got the bitrate mixed-up in your previous comment.

Anyhow, the issue is with your amplifier then...

The digital muxer converts a DTS-HD HighRes? stream into a DTS-HD MA stream so playing DTS-HD HighRes? will appear to the amplifier as if it was DTS-HD MA, and this is what it will display, unless HBR Passthrough was disabled (in which case the bitrate is forced to 6.144Mbit/s).

There's no difference between a DTS-HD MA or DTS-HD High-Res track other than their bitrates: e.g. a 6.11Mbit/s DTS-HD MA is the same as a DTS-HD High-Res and you can't tell them appart.

A DTS-HD MA could very well be just have a 6.144Mbit/s and you can't distinguish those with a DTS-HD High-Res frame.

For example; some bluray audio starts with a DTS-HD MA at just 6.144Mbit/s and later switch to the maximum of 24Mbit/s... (like many Disney cartoons where the into is DTS-HD MA 6.144Mbit/s switching later to 24Mbit/s).

Your patch would break this and would introduce silent for whenever the audio stream changed bitrates.

Alternatively, playing a 24Mbit/s DTS-HD MA, forcing the rate to 6.144MBit/s will appear as a DTS-HD HighRes? to your amp.

What it means is that your amplifier seems unable to play 6.144Mbit/s DTS-HD MA. That would break a lot of playback such as this one: http://www.avenard.org/files/media/mediatest/audiotest/Surround/DTS-HD%20MA/00048.m2ts (this is a DTS-HD MA @ 6.114Mbit.s stream)

comment:4 Changed 8 years ago by JYA

For the record; user is using a nvidia GT240. nVidia GT2xx and earlier do *not* support HBR digital audio. Only nVidia 3xx and later do.

When using a nVidia 2xx or ion/9400m ; make sure you uncheck HBR in the advanced audio settings: this will provide the most consistent results.

Note: See TracTickets for help on using tickets.