Opened 8 years ago

Closed 8 years ago

#9845 closed Bug Report - Crash (Fixed)

Segfault when starting Live TV

Reported by: skd5aner <skd5aner@…> Owned by: danielk
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm getting segfaults about 20% of the time when trying to launch Live TV. It's repeatable, but I've not yet been able to understand exactly how to reproduce it. Sometimes it crashes, sometimes it doesn't. I was able to get a backtrace and launch mythfrontend with gdb and luckily catch one of the segfaults. I do not know of an exact behavior pattern that will cause the segfault, other than launching live tv.

Attached is the backtrace, log with -v playback (if I remember correctly), and version info.

Attachments (3)

mythlivetvsegf.log (62.2 KB) - added by skd5aner <skd5aner@…> 8 years ago.
gdb.txt (74.2 KB) - added by skd5aner <skd5aner@…> 8 years ago.
version.txt (685 bytes) - added by skd5aner <skd5aner@…> 8 years ago.

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by skd5aner <skd5aner@…>

Attachment: mythlivetvsegf.log added

Changed 8 years ago by skd5aner <skd5aner@…>

Attachment: gdb.txt added

Changed 8 years ago by skd5aner <skd5aner@…>

Attachment: version.txt added

comment:1 Changed 8 years ago by beirdo

Owner: Janne Grunau deleted
Status: newassigned

comment:2 Changed 8 years ago by skd5aner <skd5aner@…>

Reporting back some recent testing...

After disabling the the setting for displaying the guide at the startup of live TV, I'm no longer able to reproduce this segfault. When I re-enable the setting, I sporadically get segfaults again.

comment:3 Changed 8 years ago by danielk

Milestone: unknown0.25
Owner: set to danielk
Status: assignedaccepted

comment:4 Changed 8 years ago by danielk

skd5aner, this does not look to be related to #10416. But I'm not able to reproduce.

Are you still able to reproduce this?

comment:5 Changed 8 years ago by danielk

Status: acceptedinfoneeded

comment:6 Changed 8 years ago by skd5aner <skd5aner@…>

I tested a few months back (December) with the latest version of 0.24-fixes at the time, and was able to reproduce (sporadically) if I had the setting to enable the EPG to show when Live TV is started. If I disabled that feature, the segfaults disappeared.

I'll attempt to test again over the next day or so with the setting re-enabled and report back. Please let me know if there's anything specific you'd like me to attempt/report back with.

comment:7 Changed 8 years ago by skd5aner <skd5aner@…>

I was able to reproduce this very easily using v0.24.1-112-g40f3bae

Turn on the setting to show the EPG when starting Live TV, and it segfaulted immediately when I used the Live TV jump point.

comment:8 Changed 8 years ago by danielk

skd5aner, I need you to test with the master branch. I've a segfault fix in the guide there that has not been backported to 0.24 fixes.

comment:9 Changed 8 years ago by danielk

Resolution: Fixed
Status: infoneededclosed

I believe this is fixed in master. Please ping if you are able to reproduce.

Note: See TracTickets for help on using tickets.