Opened 8 years ago

Closed 6 years ago

#9851 closed Bug Report - General (Duplicate)

DVD internal player stutters every few minutes

Reported by: brad@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: 0.24-fixes
Severity: medium Keywords: dvd internal stutters
Cc: Ticket locked: no

Description

After performing the latest upgrades reported by apt, my DVD playing now is not working as before. It stutters every few minutes. It's happened on different discs that I know to be okay and worked before the update.

I see the following repeated in the mythfrontend.log file that coincides with the brief pause in playback:

* libdvdread: CHECK_VALUE failed in dvdread/nav_read.c:264 * * for dsi->dsi_gi.zero1 == 0 *

2011-06-14 13:40:10.660 Player(0): Waited 100ms for video buffers AAAAAAAddAAALAADA 2011-06-14 13:40:10.668 Player(0): Waited 100ms for video buffers AAAAAAAddAAALAADA

* libdvdread: CHECK_VALUE failed in dvdread/nav_read.c:264 * * for dsi->dsi_gi.zero1 == 0 *

2011-06-14 13:40:10.677 Player(0): Waited 100ms for video buffers AAAAAAAddAAALAADA 2011-06-14 13:40:10.685 Player(0): Waited 100ms for video buffers AAAAAAAddAAALAADA 2011-06-14 13:40:10.763 AFD Warning: Audio 54441 ms behind video but already 180 video frames queued. AV-Sync might be broken. 2011-06-14 13:40:10.764 AFD Warning: Audio 54410 ms behind video but already 180 video frames queued. AV-Sync might be broken. 2011-06-14 13:40:10.764 AFD Warning: Audio 54444 ms behind video but already 180 video frames queued. AV-Sync might be broken. 2011-06-14 13:40:10.777 AFD Warning: Audio 54413 ms behind video but already 180 video frames queued. AV-Sync might be broken. 2011-06-14 13:40:10.777 AFD Warning: Audio 54383 ms behind video but already 180 video frames queued. AV-Sync might be broken. 2011-06-14 13:40:10.777 AFD Warning: Audio 54416 ms behind video but already 180 video frames queued. AV-Sync might be broken. 2011-06-14 13:40:10.778 AFD Warning: Audio 54449 ms behind video but already 180 video frames queued. AV-Sync might be broken. 2011-06-14 13:40:10.810 AFD Warning: Audio 54483 ms behind video but already 180 video frames queued. AV-Sync might be broken. 2011-06-14 13:40:10.811 AFD Warning: Audio 54452 ms behind video but already 180 video frames queued. AV-Sync might be broken.

* libdvdread: CHECK_VALUE failed in dvdread/nav_read.c:264 * * for dsi->dsi_gi.zero1 == 0 *

I did reboot after the upgrades.

Versions: Description: Ubuntu 10.04.2 LTS Release: 10.04

mythtv:

Installed: 2:0.24.1+fixes.20110614.1be38ea-0ubuntu0mythbuntu1 Candidate: 2:0.24.1+fixes.20110614.1be38ea-0ubuntu0mythbuntu1 Version table:

* 2:0.24.1+fixes.20110614.1be38ea-0ubuntu0mythbuntu1 0

500 http://ppa.launchpad.net/mythbuntu/0.24/ubuntu/ lucid/main Packages 100 /var/lib/dpkg/status

0.23.0+fixes24158-0ubuntu2 0

500 http://us.archive.ubuntu.com/ubuntu/ lucid/multiverse Packages

Change History (4)

comment:1 Changed 8 years ago by beirdo

Owner: Janne Grunau deleted
Status: newassigned

comment:2 Changed 8 years ago by beirdo

Component: MythTV - Video PlaybackMythTV - DVD Playback
Status: assignednew

comment:3 Changed 7 years ago by markk

Is this still an issue?

This honestly doesn't look like a MythTV problem. The code referenced by libdvdread hasn't changed in years and the root cause of all that logging is the read error from libdvdread. What other system libraries were changed at the same time? did you change any hardware? etc etc

comment:4 Changed 6 years ago by peper03

Resolution: Duplicate
Status: newclosed

The 'libdvdread' errors indicate that a reserved field that should be zero isn't, but as this field is not actually used anywhere (apart from checking that it's zero), not being zero is not going to be the cause of any playback issues.

The '... already 180 video frames queued' errors did sometimes occur on certain titles (in particular Pixar titles in my experience) due to a timecode discontinuity. The effect was that the audio played normally but the picture would freeze for two or three seconds. This was reported and fixed in #11371.

As I have encountered both these issues ('invalid' values in fields, and playback freezing) together on Pixar DVDs, I'm going to take a leap of faith and close this ticket as a duplicate to #11371.

If the issue still persists with a more recent version of MythTV (>=0.26-fixes), please open a new ticket with frontend traces using the parameters '-v playback --loglevel=debug'.

Note: See TracTickets for help on using tickets.