Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 21 months ago

Last modified 21 months ago

#9861 closed Patch - Feature (fixed)

[PATCH] Rotate IPhone videos for proper playback

Reported by: Dave Badia <dbadia@…> Owned by: stichnot
Priority: minor Milestone: 0.26
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

IPhone videos can appear upside down in myth depending on the orientation of the phone when the video was captured. This patch checks the MOV metadata to detect the orientation and flips the frames if necessary. The MOV metadata is read by ffmpeg so this upstream ffmpeg patch is required to be merged into myth: http://git.videolan.org/?p=ffmpeg.git;a=commit;h=d3cef0a85b7d3fd133a3349341646fe15aeb0030

The flip is executed differently depending on the decoding/rendering method:

VDPAU: Simple swap of coordinates as suggested by the nvidia documentation
Software: Added a new filter called vflip. This filter will be automatically applied when needed.
XVMC: Didn't bother since it's going away

Test both active types and it's working well for me

This patch can be safely merged into myth prior to the ffmpeg patch - it just won't execute until that's done.

Attachments (3)

mov-flip-both (13.3 KB) - added by Dave Badia <dbadia@…> 3 years ago.
mov-flip-both2 (13.9 KB) - added by Dave Badia <dbadia@…> 2 years ago.
new patch that applies cleanly to master
mov-flip-both3 (13.7 KB) - added by Dave Badia <dbadia@…> 22 months ago.
New patch that applies cleanly to master

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by Dave Badia <dbadia@…>

comment:1 Changed 3 years ago by robertm

  • Component changed from Plugin - MythVideo to MythTV - Video Playback
  • Owner changed from robertm to janne
  • Type changed from Patch - Bug Fix to Patch - Feature

This doesn't actually have anything to do with mythvideo, changing component and type (since it's not a bug fix either)

comment:2 Changed 2 years ago by beirdo

  • Owner changed from janne to markk
  • Status changed from new to assigned

Sending this somewhere where it might get some attention.

Changed 2 years ago by Dave Badia <dbadia@…>

new patch that applies cleanly to master

comment:3 Changed 2 years ago by markk

  • Owner markk deleted

comment:4 Changed 23 months ago by stichnot

  • Owner set to stichnot
  • Status changed from assigned to accepted

Dave, do you have an updated patch that you can upload?

Changed 22 months ago by Dave Badia <dbadia@…>

New patch that applies cleanly to master

comment:5 Changed 21 months ago by Dave Badia <dbadia@…>

  • Resolution set to fixed
  • Status changed from accepted to closed

In 60cf735196cf267226dd8f7ec937a82fb5f8d4b3/mythtv:

Fixes #9861. Rotate upside-down iPhone videos.

Thanks to David Badia for the patch (slightly modified to eliminate
compiler warnings and conform to coding standards).

This has been tested under the Slim and VDPAU Normal playback profiles.

Signed-off-by: Jim Stichnoth <jstichnoth@…>

comment:6 Changed 21 months ago by stichnot

  • Milestone changed from unknown to 0.26

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.