Opened 9 years ago

Closed 9 years ago

#9869 closed Bug Report - General (Duplicate)

No audio on analogue live TV and recordings

Reported by: yianniv <yiannividalis@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: yes

Description

Unfortunately, in my area we still use analogue tv, the switch over will not happen for another year or so. It's been about a month (yes, I know) that the channels from the analogue source play without sound. Tuning is (_L), but tuning is (_LMS) on the dvb (we do have 4 digital channels!!!) and the satellite, too.

The info OSD on livetv (pressing i,i) shows no icon for the codec used, but shows stereo underneath (Arclight theme).

Both analogue tv cards use the Saa7134 chip and the audio dev is /dev/dsp1 for both cards (they are on two different backends).

Older analogue recordings play fine.

DVB, satellite and hdpvr recordings play fine (well, at the moment there is no picture in the sat channels but we have some very strong winds here so, I'm not worried yet). I don't watch much tv.

version:

MythTV Version : v0.25pre-2416-gad8ced5
MythTV Branch : master
Network Protocol : 66
Library API : 0.25.20110620-2
QT Version : 4.7.3
Options compiled in:
 linux release use_hidesyms using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_hdpvr using_iptv using_libfftw3 using_libxml2 using_lirc using_mheg using_opengl_video using_qtdbus using_qtwebkit using_v4l2 using_v4l1 using_x11 using_xrandr using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2

I don't know if it's relevant, but when I open live tv, two .nuv or .mpg files are created, the first with zero byte length and the second is created after some secs, which is the one that holds the actual recording. I am noticing that this is regular lately. If it makes any difference, I checked the folders and it seems this happens when the MB has the TV card but the files are created on the SBE (more free space, I suppose).

Attachments (1)

notvsound.log (62.3 KB) - added by yianniv <yiannividalis@…> 9 years ago.
mythfrontend -v channel,audio,playback

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by yianniv <yiannividalis@…>

Attachment: notvsound.log added

mythfrontend -v channel,audio,playback

comment:1 Changed 9 years ago by patrick@…

The problem does still exist. Is there any idea when this will be fixed? Is there anything to help fixing this problem.

comment:2 Changed 9 years ago by Raymond Wagner

Component: MythTV - GeneralMythTV - Recording
Owner: set to danielk
Severity: mediumhigh
Ticket locked: set

Please read the Ticket HowTo. Bumping tickets, posting that you are having the same problem but giving no additional information, or querying the status of a solution will result in the ticket being locked.

This issue only affects analog framegrabbers, which are not currently in use by any developer, are recommended against in favor of MPEG encoders, and that many developers feel support for should be dropped entirely. Further, it only seems to affect the developmental branch, and things breaking are par for the course when running developmental code. If this is something that can be reliably reproduced by one of the developers, it will likely be resolved in preparation for release of 0.25. In the mean time, you can dig into the code and try to come up with a patch yourself, or drop back to the latest stable 0.24 release.

comment:3 Changed 9 years ago by Raymond Wagner

Resolution: Duplicate
Status: newclosed

Duplicate of #9825. Issues solved by patches attached to other ticket.

Note: See TracTickets for help on using tickets.