Opened 8 years ago

Closed 8 years ago

#9895 closed Bug Report - General (fixed)

MythUI File Browser broken in master

Reported by: robertm Owned by:
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The MythUI File Browser widget is no longer able to browse remote storage groups. I haven't tried it in a really long time but find myself needing this functionality again. It opens, but you get no remote images loaded, and an onslaught of:

LoadScaleImage?(myth://Screenshots@192.168.0.99//Arrested Development Season 1x10_screenshot.jpg) failed to load image

for every onscreen image in the logs. ISTR recent LoadScaleImage? changes, I'll see if I can narrow down the cause.

You can test remote/Storage group browsing of images by clicking the "local" browse buttons in the Edit Metadata dialog of the Video gallery.

Change History (2)

comment:1 Changed 8 years ago by robertm

Further info:

When trying to open the remote images, the backend complains:

2011-07-02 18:22:03.353686 I [21181/21235] ProcessRequest? fileringbuffer.cpp:343 (OpenFile?) - FileRingBuf?() Error: RingBuffer::RingBuffer?(): Failed to open remote file () 2011-07-02 18:22:03.353938 I [21181/21235] ProcessRequest? programinfo.cpp:2068 (QueryBasename?) - QueryBasename? found no entry for 0 @ 2011-07-02T18:22:03 2011-07-02 18:22:03.354188 I [21181/21235] ProcessRequest? programinfo.cpp:2068 (QueryBasename?) - QueryBasename? found no entry for 0 @ 2011-07-02T18:22:03

So looks like it's trying to create a pginfo just to open a remote file ringbuffer?

comment:2 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: newclosed

Fix MythUI File Browser.

It appears that with recent changes to SG file listing methods, the returned files are often/usually prepended with a slash, and having a interstitial seems to throw remotefile into a fit. This just adjusts the MythUIfileBrowser to work again so that I can get on with using it. I'll look for a more elegant solution once I finish my current tasks.

Fixes #9895.

Branch: master Changeset: 43a26409d852c9fe67d3fc937fd6e3cbd1c987bf

Note: See TracTickets for help on using tickets.