Opened 14 years ago

Closed 14 years ago

#990 closed defect (fixed)

Playback problem when skipping back during live-tv from a dvb channel to a pvr-x50 channel

Reported by: tralph11@… Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The problem is reproduced using SVN 8554 by the following sequence:

-enter live-tv -tune to a pvr-x50 channel -change channel to a dvb channel (720p or 1080i) -skip back into the prior pvr-x50 recording

The display with deinterlacing turned OFF shows up using ~1/4th the screen and with deinterlacing (Bob) turned ON the image starts repeating horizontally and vertically across the entire screen. The symtoms were the same for 720p and 1080i dvb channels.

If you need any logs let me know. It is 100% reproducible on my end.

Change History (3)

comment:1 Changed 14 years ago by danielk

Milestone: 0.19
Owner: changed from Isaac Richards to danielk

It looks like the video output is not being reinitialized for the new frame size on the skip back.

comment:2 Changed 14 years ago by danielk

(In [8652]) References #1058, and references #990.

This adds a verbose to VideoOutputXv? when shm buffers are created. This should make any problems on buffer creation debuggable.

comment:3 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [8653]) Fixes #990. Reinitialize VideoOutput? on discontinous ringbuffer switches.

Note: See TracTickets for help on using tickets.