Opened 9 years ago

Closed 9 years ago

#9932 closed Bug Report - General (Fixed)

No TV metadata download when Season = 0 and Episode = 0

Reported by: yiannividalis@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In the West Wing, there is a special which is actually Season 0 Episode 0. No metadata is downloaded because the episode is treated like a movie.

2011-07-23 15:51:37.633835 I  Running Grabber: /usr/share/mythtv/metadata/Movie/tmdb.py -l el -M The West Wing

Additionally, and I think this could be a separate bug, the script doesn't time out when it fails to find a title and I have to kill the mythfrontend program.

No metadata is downloaded even from the Edit Details Screen when I set Season = 0 and Episode = 0. This is by design I think, but in this particular case it doesn't work.

MythTV Version : v0.25pre-2865-g546af2f
MythTV Branch : master
Network Protocol : 69
Library API : 0.25.20110722-1
QT Version : 4.7.3
Options compiled in:
 linux release use_hidesyms using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_hdpvr using_iptv using_libfftw3 using_libxml2 using_lirc using_mheg using_opengl_video using_qtdbus using_qtwebkit using_v4l2 using_v4l1 using_x11 using_xrandr using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2

Change History (2)

comment:1 Changed 9 years ago by Github

Fix incorrect cast that prevented a failed lookup from returning in the Video Gallery.

Refs #9932.

Branch: master Changeset: 883126db4b1cdc231ee8eff568928a204990ff12

comment:2 Changed 9 years ago by robertm

Resolution: Fixed
Status: newclosed

The issue with The West Wing is bogus metadata. Episode indexes *must* start at 1, not 0. This is an issue which needs fixing at TVDB.

Thus, the rest of this ticket is "wontfix."

http://forums.thetvdb.com/viewtopic.php?f=7&t=6980

Note: See TracTickets for help on using tickets.