Opened 8 years ago

Closed 8 years ago

#9936 closed Bug Report - General (fixed)

No way to exit the frontend after changing the theme or menu layout in the settings

Reported by: paulh Owned by: sphery
Priority: blocker Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If you change the theme using the theme downloader or change the menu layout in the settings then you can't exit the FE by escaping out of it.

I'm sure this is a fairly new regression introduced in the last few weeks.

Change History (2)

comment:1 Changed 8 years ago by beirdo

Owner: set to sphery
Status: newassigned

comment:2 Changed 8 years ago by Github

Resolution: fixed
Status: assignedclosed

Fix exit after changing themes.

In caea1c7d71 , the ThemeChooser?'s calls to the Reload Theme jump point were modified to include the pop = false argument so that the "old" theme's main menu screen wasn't shown prior to loading the new theme. Unfortunately, this left 2 extra screens on the stack, so we would never again attempt to exit because it looked like we weren't at the top of the main menu.

I am working on another approach that will provide behavior closer to that intended in caea1c7d71, but it's grown large and complicated enough that it will take a while to complete, so I'm committing this change while I finish the other approach.

Fixes #9936.

Branch: master Changeset: e316854648aa28f1d30e443caa307e4f9cb0275c

Note: See TracTickets for help on using tickets.