Opened 8 years ago

Closed 8 years ago

#9940 closed Patch - Bug Fix (fixed)

Patch: Static analysis null pointer deference in hdhomerun_device.c

Reported by: Gary Buhrmaster <gary.buhrmaster@…> Owned by: robertm
Priority: trivial Milestone: 0.25
Component: MythTV - HDHomeRun Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Running cppcheck on the mythtv code, there is a valid null pointer deference error reported in hdhomerun_device.c. A patch is attached.

Attachments (1)

hdhomerun_device.c.patch (732 bytes) - added by Gary Buhrmaster <gary.buhrmaster@…> 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by Gary Buhrmaster <gary.buhrmaster@…>

Attachment: hdhomerun_device.c.patch added

comment:1 Changed 8 years ago by robertm

Status: newinfoneeded_new

Hi Gary,

Have you submitted this patch to SiliconDust?? Which version of MythTV is this against? We have different versions of the library in each release.

comment:2 Changed 8 years ago by Silicondust

Problem confirmed by code review. Patch approved for trunk.

Nick - Silicondust

comment:3 Changed 8 years ago by Silicondust

RE backporting:

This bug probably goes back a long way, however no need to backport as this codepath is theoretical under Linux (requires calloc to return NULL and I don't believe Linux will do that due to the way it lazy allocates memory).

Nick

comment:4 Changed 8 years ago by robertm

Status: infoneeded_newnew

Will apply to master for continuity's sake, thanks.

comment:5 Changed 8 years ago by robertm

Milestone: unknown0.25
Owner: changed from Silicondust to robertm
Status: newassigned
Version: UnspecifiedTrunk Head

comment:6 Changed 8 years ago by Github

Resolution: fixed
Status: assignedclosed

libhdhomerun: Fix NULL pointer dereference.

Fixes #9940 with a patch provided by Gary Buhrmaster, OK'd by Nick K from SiliconDust?.

Branch: master Changeset: cbed8d8a8e0ceb37d1ba19338adab6e6fa2d96bc

Note: See TracTickets for help on using tickets.