Opened 8 years ago

Closed 8 years ago

#9958 closed Bug Report - General (Works for me)

Escape key functionality is unchangeable in certain instances

Reported by: cnidus.eudoxus@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24.1
Severity: low Keywords:
Cc: Ticket locked: no

Description

The problem is this: I want the 'backspace' key to function as the 'ESC' key does. However, I am not able to re-map the 'backspace' key in all situations. Neither the 'edit keys' interface nor the MythWeb interface are able to re-map the functionality of the 'ESC' key in all situations. Work-arounds exist but are not suitable (e.g. I don't use lirc). As an example of the problematic behavior, the re-mapped 'backspace' key does not operate as expected in the info screen; i.e. press 'i' key to bring up the information on a recording. The re-mapped 'backspace' key does not clear the screen; only by pressing the 'ESC' key can this screen be cleared. This inconsistency in the behavior of the 'backspace' key lowers the WAF. Thank you.

Change History (3)

comment:1 Changed 8 years ago by paulh

As an example of the problematic behavior, the re-mapped 'backspace' key does not operate as expected in the info screen; i.e. press 'i' key to bring up the information on a recording. The re-mapped 'backspace' key does not clear the screen; only by pressing the 'ESC' key can this screen be cleared. This inconsistency in the behavior of the 'backspace' key lowers the WAF. Thank you.

That's because the active widget always gets to handle any key presses first and the browser widget by default has Backspace bound to the Back action. You would need to change or remove the Backspace key for that action for things to work as you want.

Any other place where it doesn't work?

comment:2 in reply to:  1 Changed 8 years ago by cnidus.eudoxus@…

Replying to paulh:

That's because the active widget always gets to handle any key presses first and the browser widget by default has Backspace bound to the Back action. You would need to change or remove the Backspace key for that action for things to work as you want.

Thanks a ton. That fixed the problem in under an hour when I had been struggling with this for weeks. I think my problem, essentially, was that I did not recognize that the browser widget controlled the info screen. Also, no one on the users list was able to recognize that point either. And, of course, the wiki was of no help. Why isn't that screen being controlled by the global settings?

Any other place where it doesn't work?

Actually, I was seeing that same behavior when creating a new recording profile (but not when creating new playback profile). But the fix seems to have corrected that problem as well. Thanks again.

comment:3 Changed 8 years ago by paulh

Resolution: Works for me
Status: newclosed
Note: See TracTickets for help on using tickets.