Modify

Opened 6 years ago

Closed 5 years ago

#9967 closed Bug Report - General (Duplicate)

Mythweb doesn't store settings, displays warnings in show details

Reported by: Andrew Junev <a-j@…> Owned by: kormoc
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.24.1
Severity: medium Keywords: mythweb NoTrans
Cc: Ticket locked: no

Description

MythWeb doesn't store new settings under Settings --> Date Formats (at least in there). For example, I'd like to change "Recorded programs" from "%a %b %e, %Y (%I:%M %p)" to "%a %b %e, %Y (%H:%M)". When I click "Save" - the page reloads and I see new (updated) setting, but it never gets active. And if I return back to settings page I see the old (default?) date format string again.

Also, every time I open a TV Show details while browsing TV Listings via MythWeb, I get the following warnings on top of the web page:

Warning at /usr/share/mythweb/modules/tv/detail.php, line 310: !NoTrans: Invalid argument supplied for foreach()!!

Warning at /usr/share/mythweb/modules/_shared/tmpl/default/header.php, line 16: !NoTrans: Cannot modify header information - headers already sent by (output started at /usr/share/mythweb/includes/errors.php:150)!!

Not sure if these two are related, but I think it all started after an upgrade from 0.23 to 0.24. And I'm currently on 0.24.1 (Fedora 13, RPMFusion repos):

$ mythbackend --version Please attach all output as a file in bug reports. MythTV Version : 0.24.1-2.fc13 (3657f313ac) MythTV Branch : Network Protocol : 63 Library API : 0.24.20110505-1 QT Version : 4.6.3 Options compiled in:

linux release using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Attachments (0)

Change History (9)

comment:1 Changed 6 years ago by wagnerrp

  • Status changed from new to infoneeded_new

What version of PHP are you using?

comment:2 Changed 6 years ago by Andrew Junev <a-j@…>

$ php -v

PHP 5.3.6 (cli) (built: Mar 17 2011 21:19:28) Copyright (c) 1997-2011 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies

comment:3 Changed 6 years ago by Martin Bene <martin.bene@…>

The problem with storing the date settings is a duplicate of Ticket 9833 which also contains a patch for the issue.

comment:4 Changed 6 years ago by Andrew Junev <a-j@…>

Ah, great! Date settings are properly stored after applying the patch! Thanks a lot for that!

Warnings in a show details are still there though:

Warning at /usr/share/mythweb/modules/tv/detail.php, line 310: !NoTrans: Invalid argument supplied for foreach()!!

Warning at /usr/share/mythweb/modules/_shared/tmpl/default/header.php, line 16: !NoTrans: Cannot modify header information - headers already sent by (output started at /usr/share/mythweb/includes/errors.php:150)!!

comment:5 Changed 6 years ago by wagnerrp

  • Status changed from infoneeded_new to new

comment:6 Changed 6 years ago by zarthan@…

I had the same errors and it turned out to be a crashed database table. Running the table repair from Mythweb Settings fixed the problem.

comment:7 Changed 6 years ago by a-j@…

All database tables have an "OK" status in MythWeb. I made an "extended check" - and it also showed OK for each table. I still clicked "Repair Tables", but the repair didn't change anything, at least I see no changes and the errors are still there.

comment:8 Changed 5 years ago by Andrey Zhunev <a-j@…>

I learned that the php warnings are related to Ticket #10142. With the latest mythweb (either 0.25.2 or 0.26 - both work for me) and patches from #10142 applied manually, I finally get no warnings!

comment:9 Changed 5 years ago by kenni

  • Resolution set to Duplicate
  • Status changed from new to closed

Thank you for reporting back.

Closing as duplicate of #10142 as that ticket contains patches.

Add Comment

Modify Ticket

Action
as closed The owner will remain kormoc.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.