Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#9971 closed Patch - Feature (Won't Fix)

Improve CrystalHD decoding for BCM 70012

Reported by: czhang1974@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Video Decoding Version: 0.24-fixes
Severity: medium Keywords: crystalhd
Cc: Ticket locked: no

Description

This patch fixes the green overlay problem reported in the following thread on the bcm70012.

http://www.gossamer-threads.com/lists/mythtv/dev/453116

The default output format from CrystalHD on the bcm70012 is NV12, not YV12. It can be changed to use YV12 by setting some flags if we use the DtsProcOutput? instead of DtsProcOutputNoCopy?, but further reading of the library source code shows that it was converted to YV12 in software anyways. The hardware output is always in NV12, so there is no gain in using YV12.

I also had to make sure that the buffer is always released after decoding. I am still not sure why the code checked for mpa_pic.data[3] before calling the release_buffer, which effectively blocked the call since that would always be NULL for the crystalhd decoder. It most likely is breaking something else that I don't know about, but I will leave that to someone more familiar with the other private decoders.

This now works reasonably well for 720P on my AppleTV. 1080i is still having serious stuttering problem that I can't find the root cause of yet.

Attachments (1)

bcm70012.patch (3.5 KB) - added by czhang1974@… 8 years ago.
crystalhd bcm70012 patch

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by czhang1974@…

Attachment: bcm70012.patch added

crystalhd bcm70012 patch

comment:1 Changed 8 years ago by Raymond Wagner

Owner: set to markk
Status: newassigned

comment:2 Changed 8 years ago by markk

Milestone: unknown0.25
Status: assignedaccepted

comment:3 Changed 8 years ago by markk

Finally managed to test this in master. Unfortunately, while some streams play others are pretty broken. From memory, the BCM70012 needs an alignment fix for streams that are not 'normal' widths of 720 or 1920. Additionally, some streams that are straightforward 1080p still look slightly broken.

I'll see what I can do.

(N.B. not regression tested with the BCM70015 either)

comment:4 Changed 7 years ago by markk

Owner: markk deleted
Status: acceptedassigned

comment:5 Changed 7 years ago by beirdo

Milestone: 0.25unknown
Status: assignednew

comment:6 Changed 6 years ago by stuartm

Resolution: Won't Fix
Status: newclosed

I don't think any of the current developers own the hardware to work on this issue. Mark identified issues with the attached patch so this ticket is going nowhere. We don't claim to support the BCM 70012 making this a new feature, not a bug fix.

Instead of leaving the ticket open indefinitely I'm going to close it. If someone with the appropriate hardware takes an interest in adding working support for the 70012 they can open a new ticket.

comment:7 Changed 6 years ago by stuartm

Type: Patch - Bug FixPatch - Feature
Note: See TracTickets for help on using tickets.