Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9995 closed Bug Report - General (Duplicate)

Mythplugins Master fails to build (e7003f9)

Reported by: superm1@… Owned by: paulh
Priority: minor Milestone: unknown
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by beirdo)

MythTV config:

# Basic Settings
Compile type              debug
Compiler cache            yes
DistCC                    no
qmake                     /usr/bin/qmake
install prefix            /usr
runtime prefix            /usr
CPU                       x86 x86_32 (i686)
yasm                      yes
MMX enabled               yes
MMX2 enabled              yes
3DNow! enabled            yes
3DNow! extended enabled   yes
SSE enabled               yes
SSSE3 enabled             yes
CMOV enabled              yes

# Input Support
Joystick menu             yes
lirc support              yes
Video4Linux sup.          yes (v1 yes)
ivtv support              yes
HD-PVR support            yes
FireWire support          yes
DVB support               yes [/usr/include]
DVB-S2 support            yes
HDHomeRun support         yes
IPTV support              yes
ASI support               no

# Sound Output Support
PulseAudio support        yes
OSS support               yes
ALSA support              yes
JACK support              no
libfftw3 support          no

# Video Output Support
x11 support               yes
xrandr support            yes
xv support                yes
VDPAU support             yes
VAAPI support             no
CrystalHD support         no
OpenGL video              yes
MHEG support              yes
libass subtitle support   no

# Misc Features
multi threaded libavcodec yes
libxml2 support           no [/usr/include/libxml2]
Frontend                  yes
Backend                   yes
OpenGL ES 2.0             no

# Bindings
bindings_perl             yes
Perl config options       INSTALLDIRS=vendor
bindings_python           yes
bindings_php              yes

# mythffmpeg Options
mp3lame                   no
xvid                      no
x264                      no

Mythplugins config:

Configuration settings: 
 
        qmake          /usr/bin/qmake
 
        MythArchive    plugin will be built
        MythBrowser    plugin will be built
        MythGallery    plugin will be built
        MythGame       plugin will be built
        MythMusic      plugin will be built
        MythNetvision  plugin will be built
        MythNews       plugin will be built
        MythWeather    plugin will be built
        MythZoneMinder plugin will be built
        OpenGL         support will be included in MythGallery
        EXIF           support will be included in MythGallery
        Dcraw          support will not be included in MythGallery
        OpenGL         support will be included in MythMusic
        libvisual      support will be included in MythMusic
        FFTW v.3       support will be included in MythMusic
        SDL            support will be included in MythMusic

Here's a snippet of the error:

ccache g++ -c -pipe -march=i686 -fPIC -g -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -fvisibility-inlines-hidden -Wmissing-declarations -fvisibility=hidden -g -D_REENTRANT -Wall -W -DPIC -fPIC -D_GNU_SOURCE -DPREFIX="/usr" -DMMX -Di386 -D_FILE_OFFSET_BITS=64 -DMPLUGIN_API -DQT_PLUGIN -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I../../../debian/tmp/usr/include -I/usr/include -I/usr -I/usr/include -I../../../debian/tmp/usr/include/mythtv -I../../../debian/tmp/usr/include/mythtv/libmythbase -I../../../debian/tmp/usr/include/mythtv/libmythui -I../../../debian/tmp/usr/include/mythtv/libmyth -I/usr/include/mythtv -I/usr/include/mythtv/libmythui -I. -o moc_sourceManager.o moc_sourceManager.cpp
ccache gcc -c -pipe -g -D_REENTRANT -Wall -W -DPIC -fPIC -D_GNU_SOURCE -DPREFIX="/usr" -DMMX -Di386 -D_FILE_OFFSET_BITS=64 -DMPLUGIN_API -DQT_PLUGIN -DQT_WEBKIT_LIB -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/Qt3Support -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I../../../debian/tmp/usr/include -I/usr/include -I/usr -I/usr/include -I../../../debian/tmp/usr/include/mythtv -I../../../debian/tmp/usr/include/mythtv/libmythbase -I../../../debian/tmp/usr/include/mythtv/libmythui -I../../../debian/tmp/usr/include/mythtv/libmyth -I/usr/include/libvisual-0.4 -I/usr/include/taglib -I/build/buildd/mythtv-0.25.0~master.20110818.e7003f9/debian/tmp/usr/include/cdda -I/usr/X11R6/include -I. -o zoom_filter_sse2.o goom/zoom_filter_sse2.c
goom/zoom_filter_sse2.c: In function 'zoom_filter_sse2':
goom/zoom_filter_sse2.c:64: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
goom/zoom_filter_sse2.c:64: error: 'asm' operand has impossible constraints
make[4]: *** [zoom_filter_sse2.o] Error 1
make[4]: Leaving directory `/build/buildd/mythtv-0.25.0~master.20110818.e7003f9/mythplugins/mythmusic/mythmusic'
make[3]: *** [sub-mythmusic-make_default] Error 2
make[3]: Leaving directory `/build/buildd/mythtv-0.25.0~master.20110818.e7003f9/mythplugins/mythmusic'
make[2]: *** [sub-mythmusic-make_default] Error 2
make[2]: *** Waiting for unfinished jobs....

Full build log: http://goo.gl/NSR0x

Change History (2)

comment:1 Changed 9 years ago by beirdo

Resolution: Duplicate
Status: newclosed

Duplicate of #9994

comment:2 Changed 9 years ago by beirdo

Description: modified (diff)
Note: See TracTickets for help on using tickets.