Opened 8 years ago

Last modified 5 years ago

#10076 new Patch - Feature

Make active EIT scan in timewindow

Reported by: warpme@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: unknown
Component: MythTV - EIT Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This patch allows to make EIT active scan working in time windowed mode. If eitCrawlIdleStart is higher than 3600sec - active EIT will switch to windowed mode where collecting starts eitCrawlIdleStart number of seconds after midnight and will go for 4h time window. 4h is hard coded as I don't want to change DB schema by introducing new setting. For eitCrawlIdleStart not higher than 3600sec patch is functionally non-destructive (execution path is practically the same). Patch is not production ready, as has hardcoded 4h scan window duration and hasn't config boundaries checking.

Attachments (4)

make_EIT_start_at_time.patch (13.1 KB) - added by warpme@… 8 years ago.
0021-make_EIT_start_at_time.patch (11.3 KB) - added by warpme@… 6 years ago.
patch for 0.27-fixes
0009-make_EIT_start_at_time.patch (11.5 KB) - added by warpme@… 5 years ago.
Patch for current master
0009-make_EIT_start_at_time.2.patch (11.3 KB) - added by warpme@… 4 years ago.
Cleaned-up patch + updated for current master

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by warpme@…

comment:1 Changed 8 years ago by sphery

This is a dup of #5754. I still think it should be closed as wontfix. (Also a dup of #9765, but that one didn't have a patch.)

IMHO, this should be done the way Janne was planning (as obliquely referenced in ticket:5754#comment:25 ) such that it does not use any settings, but just always does the right thing. In other words, it performs an EIT scan occasionally and grabs data from all muxes then "sleeps" for a while. That "while" could even be dynamically tuned automatically by the grabber or just start out using some reasonable time for now and be extended later. (Ideally EITCrawIdleStart , without the overloaded meaning, would also be automatic.)

comment:2 Changed 8 years ago by warpme@…

Mike, Thx for Your time spent on this ticket. Small remarks form my side: 1\AFAK it is not exact duplicate of 5754 & 9765 as two formers realized duty cycle for EIT while my approach realizes EIT on exact given time schedule. In other words - my patch guarantees EIT will scan only within exactly defined time window; 2\I fully share Your view about desired simplicity in myth setup - so enriching setup screens about additional settings like EITscanDuration is not obvious also for me. It will be good however to have such functionality (+ settings on DB level) for tweakers like You or me; 3\Janne suggestion is nice but IMHO orthogonal to mine as I can imagine users preferring less EIT self-inteligence for more control/predictability (i.e. BE sleeping during day and commflaging/transcoding/scanningEIT at night in time-window). Oh BTW: this patch nicely workarounds 10016 & 9480 for me. While 9480 might be 9480 former patch specific, 10016 looks like not yet widely discovered bug.

comment:3 Changed 7 years ago by dekarl@…

Why do you want to make active EIT scan in timewindow?

I'm asking because I intend to unbreak idle shutdown with active EIT scan enabled. Which might make this patch unneccesary (if you want to safe power you can use idle shutdown) or neccessary (if you want to keep the guide up to date without any scheduled recording while using idle shutdown).

comment:4 Changed 7 years ago by warpme@…

Karl, Honestly speaking I not need it anymore :-). I developed this patch in times when active EIT scanner causes deadlocks in BE when LiveTV is launched. Time windowed EIT scanner allowed me to minimalize such deadlocks. Fortunately - at some point in time - Daniel fixed this bug and now I have continuously running EIT scanner without negative issues with LiveTV. Speaking about this patch current usefulness: I can imagine someone wants to setup BE for kind of batch processing at night (transcodes, etc) and have it off for rest of day. In such case it might be wise to set active EIT scanner in this time window with short idle timeout setting (as this will allow to gather as much EIT data as possible in short period of time - when BE is alive). This is for sure corner and little artificial case...

comment:5 Changed 6 years ago by warpme@…

This is updated patch for current 0.27-fixes. I decide to refresh idea with EIT scan in time window as it allows me to quite considerably save power. Having EIT window defined for most user-active MythTV window time(my case: 7PM-11PM) and setting "open_dvb_on_demand" for all my 6 tuners allows to reduce my BE idle power from 71-76W to 55-60W.

Changed 6 years ago by warpme@…

patch for 0.27-fixes

Changed 5 years ago by warpme@…

Patch for current master

comment:6 Changed 5 years ago by warpme@…

Patch for mythtv-0.28

Changed 4 years ago by warpme@…

Cleaned-up patch + updated for current master

Note: See TracTickets for help on using tickets.