Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#10079 closed Bug Report - General (Fixed)

Problem Audio on Freeview HD BBC Channels

Reported by: jyavenard Owned by: beirdo
Priority: minor Milestone:
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

AAC/LATM playback is broken when the stream change channels configuration (e.g. go from stereo to 5.1)

Samples exhibiting the problem: http://www.mediafire.com/?5zx2x3zv2g6hxys

As soon as the audio configuration change, further AAC/LATM decoding will fail with decoding error messages.

The problem is in FFmpeg and this problem was recently fixed upstream.

These two patches updates myth AAC decoder to a similar version as used in FFmpeg (some changes were excluded)

Attachments (2)

aacfix-0.24.diff (67.9 KB) - added by jyavenard 3 years ago.
aacfix-master.diff (27.1 KB) - added by jyavenard 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by jyavenard

Changed 3 years ago by jyavenard

comment:1 Changed 3 years ago by jyavenard

  • Owner set to beirdo
  • Status changed from new to assigned

comment:2 Changed 3 years ago by Github

Fix AAC/LATM playback for streams with changing config

Refs #10079.

Signed-off-by: Gavin Hurlbut <ghurlbut@…>

Branch: master
Changeset: b289778325e7a52995f6e5b37fce7f76e92d60aa

comment:3 Changed 3 years ago by beirdo

  • Milestone changed from unknown to 0.24.2
  • Resolution set to Fixed
  • Status changed from assigned to closed
  • Version changed from Unspecified to Trunk Head

Committed to both 0.24 and master.

comment:4 Changed 2 years ago by mythtv@…

Some recordings still seem to exhibit the problem, at least on 0.24. Here is a 40M sample that played in mythvideo, goes silent after the first minute or so of playback, and then continues silent, yet the same file with a chunk cut off the front, plays correctly.

http://download.glidos.net/MythTV/DoctorWho3.mpg

My guess was that adding a comment to this closed ticket was the best way to report this. Appologies if that's not the prefered way.

comment:5 Changed 2 years ago by mythtv@…

Sorry. False alarm. Ignore Comment 4. It was just confusion due to an 18-day-old release not including 2-month-old changes, plus somehow the corresponding source package including the changes when the binary didn't. Now that I have built from the source package, the problematic recordings work correctly.

comment:6 Changed 2 years ago by stuartm

  • Milestone 0.24.2 deleted

Milestone 0.24.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.