Opened 8 years ago

Closed 8 years ago

#10100 closed Bug Report - General (fixed)

After upgrading from 90fb1a7 to e763b85 hdpvr crashes mythbackend

Reported by: yiannividalis@… Owned by: danielk
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Trying either live tv or programming a recording through the hdpvr, mythbackend crashes and the message on the frontend is "Error opening switch program buffer".

Reverting to 90fb1a7 corrects it.

PCI cards (Analog tv or dvb-T) are not affected.

I am back at 90fb1a7 for now since the kids have taken over the tv so, if I should provide any logs it will have to wait until Monday.

Attachments (1)

gdb.txt (21.6 KB) - added by jpoet 8 years ago.
BT for segfault at libmythbase/iso639.h:58

Download all attachments as: .zip

Change History (6)

comment:1 Changed 8 years ago by danielk

Status: newinfoneeded_new

Please attach a backtrace for the backend and a mythbackend -v record log.

comment:2 Changed 8 years ago by jpoet

Status: infoneeded_newnew

I am also seeing a crash in this commit range. I noticed mine while trying to watch a show on the frontend, so it may be different, but I am going to assume it is the same, and put the info on this ticket.

I have narrowed down the commit that caused the crash to:

commit fc0761d3bda39d4c68db0e22d045d1394002bc97
Author: Daniel Thor Kristjansson <danielk@cuymedia.net>
Date:   Thu Oct 13 17:35:07 2011 -0400

    Remove asserts in MPEG descriptor constructors. Replace with IsValid() method that can be called after construction.

commit e85144c0fc2eceb2e244389f0949c05d13bc0023
Author: Daniel Thor Kristjansson <danielk@cuymedia.net>
Date:   Thu Oct 13 16:57:40 2011 -0400

    Converts MPEGDescriptor::DescriptorTagString() to use table instead of a long switch statement.

commit 5648df9367487bfedebd7211a88ab02536fc84da
Author: Daniel Thor Kristjansson <danielk@cuymedia.net>
Date:   Thu Oct 13 16:45:41 2011 -0400

    DescriptorID class cleanup

Program received signal SIGSEGV, Segmentation fault. 0x00007f452a20c81e in iso639_str3_to_key (iso639_2=0x0) at ../libmythbase/iso639.h:58

I am attaching a BT

Changed 8 years ago by jpoet

Attachment: gdb.txt added

BT for segfault at libmythbase/iso639.h:58

comment:3 Changed 8 years ago by danielk

Owner: set to danielk
Status: newaccepted

comment:4 Changed 8 years ago by danielk

We need to add a Parse() call to the CaptionServiceDescriptor? constructor. Something like

if (_data && !Parse())

_data = NULL;

This is a systematic error in [fc0761d3b], so I'll need to fix a few constructors.

comment:5 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: acceptedclosed

Fixes #10100. Fix regression caused by [fc0761d3b].

Cut-n-paste error + a thinko. The cut-n-paste caused it to pass my testing, despite the Probe() bogosity.

Branch: master Changeset: 376cd540a1a7dd6354933dd277c93f6447619773

Note: See TracTickets for help on using tickets.