Opened 8 years ago

Closed 8 years ago

#10134 closed Bug Report - Crash (Fixed)

mythfrontend segfaults on exit

Reported by: [R] <ginsu.squirrel@…> Owned by:
Priority: minor Milestone: 0.25
Component: MythTV - User Interface Library Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When selecting "Yes, Exit now" from the "Do you really want to exit MythTV?" menu, mythfrontend segfaults.

Attachments (2)

backtrace.txt (1.8 KB) - added by [R] <ginsu.squirrel@…> 8 years ago.
mythfrontend --version output and gdb backtrace
full-backtrace.txt (28.1 KB) - added by [R] <ginsu.squirrel@…> 8 years ago.
full backtrace

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by [R] <ginsu.squirrel@…>

Attachment: backtrace.txt added

mythfrontend --version output and gdb backtrace

Changed 8 years ago by [R] <ginsu.squirrel@…>

Attachment: full-backtrace.txt added

full backtrace

comment:1 Changed 8 years ago by Raymond Wagner

Component: MythTV - GeneralMythTV - User Interface Library
Milestone: unknown0.25
Resolution: Fixed
Status: newclosed

Problem caused by System Events triggered by destruction of the exit menu being handled after required objects are closed and deleted.

Caused by 87b89dee6c8c6a4ff
Fixed by removal in b603bf395b30611

Last edited 8 years ago by Raymond Wagner (previous) (diff)
Note: See TracTickets for help on using tickets.