Opened 8 years ago

Closed 8 years ago

#10148 closed Bug Report - Crash (Works for me)

mythbackend dies at end of HDHR Prime recording with "terminate called without an active exception"

Reported by: Don Lewis <dl-mythtv@…> Owned by: Silicondust
Priority: minor Milestone: unknown
Component: MythTV - HDHomeRun Version: 0.24.1
Severity: medium Keywords: mythbackend crash HDHomeRun
Cc: Ticket locked: no

Description

Since I've installed my HDHomeRun Prime, I've seen mythbackend occasionally crash. In this instance, just before the crash mythbackend logged the following two messages that I haven't seen before:

pure virtual method called

and

terminate called without an active exception

System is Fedora 14 x86_64 running MythTV from atrpms.

# mythbackend --version Please attach all output as a file in bug reports. MythTV Version : v0.24.1-55-g8bc2a66 MythTV Branch : fixes/0.24 Network Protocol : 63 Library API : 0.24.20110505-1 QT Version : 4.7.3 Options compiled in:

linux release using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Attachments (2)

gdb.txt (109.1 KB) - added by Don Lewis <dl-mythtv@…> 8 years ago.
backtrace from core dump
mythbackend.log (70.7 KB) - added by Don Lewis <dl-mythtv@…> 8 years ago.
mythbackend log

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by Don Lewis <dl-mythtv@…>

Attachment: gdb.txt added

backtrace from core dump

Changed 8 years ago by Don Lewis <dl-mythtv@…>

Attachment: mythbackend.log added

mythbackend log

comment:1 Changed 8 years ago by robertm

Status: newinfoneeded_new

Don,

Can you possibly test against master? The entire recorder code has been refactored, and while the Prime works for most in .24, and works well, support is only really official in .25. It would be useful to know if this is resolved there. What capture device did the Prime replace? Are you using Myth system events or any third party utility for monitoring myth status?

comment:2 Changed 8 years ago by Don Lewis <dl-mythtv@…>

It would be difficult for me to test against master since once I upgrade there is no going back. The problem occurs very infrequently, so it would probably require weeks of testing to trigger this bug, so I can't just backup my database, do a quick test with master, and then restore things to their original state. I'm kind of reluctant to try to put master into full production as a result of all the warnings from the devs.

I've got the six tuner version of the Prime with a CableCard on one side. It replaced an older two tuner HDHR as well as two Pace RNG110s that were connected using firewire. One of the RNG110s also fed an HD-PVR, which is still used. Firewire is now only used to tune the remaining RNG110. The system has been much more solid since upgrading to the Prime, with only four instances of breakage:

  • Comcast deactivated my CableCard when I turned in the STB that it replaced
  • mythbackend crashed, at the end of a recording as I recall. I think it was probably the same crash as this one, but unfortunately I didn't have crash dumps enabled.
  • The CableCard side of my Prime, which was still running the original firmware, stopped working and the channel map web page was blank. According to the release notes it looked like this bug was probably fixed so I upgraded last week.
  • The crash that triggered this bug report

comment:3 Changed 8 years ago by robertm

Still looking for the answer to the last couple of questions, please. Note that this ticket may sit unlooked at until .25, FWIW, at which point it may just be closed as "please test with .25"... it would help a lot if you could find some way to try to trigger this in master.

comment:4 Changed 8 years ago by Don Lewis <dl-mythtv@…>

I'm not using either Myth system events or any third party utility for monitoring myth status.

I really should get around to running something to restart mythbackend when it dies, but haven't done so yet.

comment:5 Changed 8 years ago by robertm

Resolution: Works for me
Status: infoneeded_newclosed

Unable to reproduce, and very unlikely to still exist in master-- if you can reproduce against master or .25 when it is released, you can open a new ticket.

Note: See TracTickets for help on using tickets.