Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10164 closed Bug Report - Hang/Deadlock (fixed)

Updating RSS Site Maps freezes FE

Reported by: amlopezalonso@… Owned by: robertm
Priority: minor Milestone: 0.25
Component: Plugin - MythNetvision Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

Updating RSS Site Maps in Browse Internet Videos takes forever freezing the FE. Also a "mythpainter.cpp ... invalid canvas" error is issued.

Regards, Antonio

Attachments (2)

gdb.zip (184.0 KB) - added by amlopezalonso@… 8 years ago.
mythtv.log (1.0 KB) - added by amlopezalonso@… 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by robertm

Status: newinfoneeded_new

"forever" in that it is literally until you kill the frontend, or "forever" as in, "I don't want to wait this long, this sucks?"

Logs?

Logs of the output of mythfillnetvision --refresh-rss?

comment:2 in reply to:  1 Changed 8 years ago by amlopezalonso@…

Replying to robertm:

"forever" in that it is literally until you kill the frontend, or "forever" as in, "I don't want to wait this long, this sucks?"

Well I had to wait more than three minutes until I kill the FE, so if it should take more than that then yes it sucks :-)

Logs?

Logs of the output of mythfillnetvision --refresh-rss?

Here, with --loglevel=debug (it stucks at the last line until I kill the FE):

2011-11-14 18:43:45.417465 C mythfillnetvision version: master [v0.25pre-3728-g861b4eb] www.mythtv.org 2011-11-14 18:43:45.417520 N Enabled verbose msgs: general 2011-11-14 18:43:45.417556 N Setting Log Level to LOG_DEBUG 2011-11-14 18:43:45.417597 I Added logging to the console 2011-11-14 18:43:45.417602 I Added database logging to table logging 2011-11-14 18:43:45.417665 N Setting up SIGHUP handler 2011-11-14 18:43:45.417866 N Using runtime prefix = /usr 2011-11-14 18:43:45.417876 N Using configuration directory = /home/toni/.mythtv 2011-11-14 18:43:45.418666 N Empty LocalHostName?. 2011-11-14 18:43:45.418671 I Using localhost value of mythtv 2011-11-14 18:43:45.426276 I Database connection created: DBManager0 2011-11-14 18:43:45.426315 I New DB connection, total: 1 2011-11-14 18:43:45.427989 I Connected to database 'mythconverg' at host: localhost 2011-11-14 18:43:45.429827 I Closing DB connection named 'DBManager0' 2011-11-14 18:43:45.429902 I Database connection created: DBManager1 2011-11-14 18:43:45.429915 I New DB connection, total: 1 2011-11-14 18:43:45.430112 I Connected to database 'mythconverg' at host: localhost 2011-11-14 18:43:45.430579 I Current locale es_ES 2011-11-14 18:43:45.430609 E No locale defaults file for es_ES, skipping 2011-11-14 18:43:45.430814 I Loading es_es translation for module mythfrontend 2011-11-14 18:43:45.518063 I Database connection created: DBManager2 2011-11-14 18:43:45.518090 I New DB connection, total: 2 2011-11-14 18:43:45.518469 I Connected to database 'mythconverg' at host: localhost

Changed 8 years ago by amlopezalonso@…

Attachment: gdb.zip added

comment:3 Changed 8 years ago by amlopezalonso@…

Also attaching a backtrace.

comment:4 Changed 8 years ago by robertm

Please provide the URLs of all subscribed RSS feeds.

Even better, please attach a file with the output of

SELECT * from internetcontent;

Please attach as a file, please do not paste directly into the ticket.

Changed 8 years ago by amlopezalonso@…

Attachment: mythtv.log added

comment:5 Changed 8 years ago by amlopezalonso@…

OK, attaching mysql output log.

comment:6 Changed 8 years ago by robertm

You haven't configured any RSS feeds-- now granted, it shouldn't hang when none are configured and I'll fix that, but what is it you expect it to be updating?

comment:7 Changed 8 years ago by robertm

And the attached backtrace is for a VAAPI playback. Please attach the correct BT.

comment:8 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: infoneeded_newclosed

MythNetvision?: Don't attempt to update RSS if none are defined.

I don't quite see how the user's issue is occurring, but this should prevent RSS update from even beginning if none are defined.

Fixes #10164, if the issue persists, will need proper --version output and a valid backtrace.

Branch: master Changeset: c6fc90fe221230dff7bf78587a1cab2f7f55b4c6

comment:9 Changed 8 years ago by amlopezalonso@…

Sorry I was a bit confused but the issue is not fixed yet for me after updating MythTV. I assume you understood (my fault) the wrong behavior was in RSS updates but it is not. It is in Site Maps updates (I loosely included RSS in the title). I will provide new logs and a proper backtrace if necessary.

Note: See TracTickets for help on using tickets.