Opened 8 years ago

Closed 7 years ago

#10171 closed Bug Report - General (Works for me)

MythMusic fails to build on Mac OS X

Reported by: ctreleaven@… Owned by: Nigel
Priority: minor Milestone: unknown
Component: Ports - OSX Version: 0.24.1
Severity: medium Keywords:
Cc: Stuart Auchterlonie Ticket locked: no

Description

Complains "symbols not found", see attached log.

Can build the frontend successfully without plugins (using osx-packager.pl). XCode 3.2.3 under Mac OS X 10.6.8 on a MacBook? Pro (Core i7).

Attachments (1)

MFE and MythMusic build error 2011Nov20.txt.zip (15.8 KB) - added by ctreleaven@… 8 years ago.
osx-packger.pl verbose build log, zipped

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by ctreleaven@…

osx-packger.pl verbose build log, zipped

comment:1 Changed 8 years ago by ctreleaven@…

Should mention I've tried the -clean and -distclean options, with no success.

comment:2 Changed 7 years ago by ctreleaven@…

Off and on, I've been trying to get a successful build including plugins. I've determined that specifying ANY plugin causes the build to fail.

To ensure it isn't just a glitch in my system, I set up a fresh .osx-packager directory and tried to build from the ground up using osx-packager.pl from the Master branch. As before, the build falls over in mythplugins.

Full log (too big to upload) can be found here: http://dl.dropbox.com/u/26787680/BuildFail_2011Dec23.txt.zip

comment:3 Changed 7 years ago by Stuart Auchterlonie

Cc: Stuart Auchterlonie added

comment:4 Changed 7 years ago by Nigel

Craig, no problems here building GIT HEAD. I'm still trying to get time/motivation to swap the tree back to 0.24.1 (or jyavenard/backports/fixes/0.24 that you last built), but your build logs look like a problem with G++ std:: namespaces.
I'm on a 10.6.7 MacBook?, and XCode 3.2.4 (not the latest). What compiler/XCode version are you using?

comment:5 Changed 7 years ago by ctreleaven@…

I was using XCode 3.2.3 when I posted the first log and since upgraded to 3.2.6. Mac OS X 10.6.8.

My build machine is an early-2011 Sandy Bridge MacBook? Pro with quad Core i7 (2.0). For more details see: MacBookPro,2

comment:6 Changed 7 years ago by nigel@…

Did a successful fixes build, checked in the Git changes to osx-packager.pl to the fixes branch of packaging repository. Compared my build log to your Nov20 one. As far as I can tell, the compilation of MythMusic source files and moc_ are the same, but linking differs thusly:

ccache g++ ...
-lmp3lame -framework OpenGL -framework AGL -lQt3Support -F/System/Library/Frameworks -m32 -L/Volumes/Backups/MythTV/.osx-packager/build/lib/mysql -m32 -lQtSql -m32 -lmysqlclient_r -lz -lm -lQtXml -lQtOpenGL -lQtGui -lQtNetwork -lQtCore

versus yours:

ccache g++ ...
-lmp3lame -lQt3Support -L/Volumes/Backups/MythTV/.osx-packager/build/lib/mysql -F/System/Library/Frameworks -m32 -m32 -lQtSql -m32 -lmysqlclient -lz -lm -lQtXml -lQtOpenGL -lQtGui -lQtNetwork -lQtCore -framework OpenGL -framework AGL

Minor differences. Some of those are due to OpenGL (you have specified one plugin, which has bypassed the default plugin configure arguments), but some are something strange with the mysql client - see the -lmysqlclient_r on my successful build?
...but I am clutching at straws here, because your Dec23 build had identical link lines for libmythmusic.dylib.
The only other idea I currently have is to disable ccache (i.e. comment it out in osx-packager.pl) and see what happens.

comment:7 Changed 7 years ago by ctreleaven@…

Thanks Nigel. I tried a couple more times today including using the fixes/0.24 version of osx-packager.pl (building both jya's branch and the regular fixes/0.24 branch) with the same results. I also tried rebooting into 32 bit mode; same results. I can upload more build logs if you want.

I'm sorry, but I can't see how to disable ccache. I know that the version of osx-packager.pl that I was using earlier did not use it but it would not hurt to try again without it. Could you give me the idiot's guide?

I guess I've have to set up a build environment on my Myth backend machine. Was hoping to do the heavy lifting with my new MacBook? Pro.

comment:8 Changed 7 years ago by Stuart Auchterlonie

Rather than disabling ccache, if you run 'ccache -C' it will clear out your cache completely and the next build will be the same as if it were disabled.

Stuart

comment:9 Changed 7 years ago by Craig Treleaven <ctreleaven@…>

Used Stuart's 'ccache -C' and re-ran build (after '-distclean' and including '-clean' options) but still no joy. Also ran 'git fsck' with no errors reported. I'll try a build on the other machine I mentioned and report back. Wonder if it is worthwhile to uninstall/reinstall XCode??

comment:10 Changed 7 years ago by Craig Treleaven <ctreleaven@…>

OK, was able to build successfully on a Core 2 Duo mini under 10.6.8 using the same version of XCode (3.2.6). Donno what the problem is with the MacBook? Pro. When I get some time, I'll uninstall/reinstall Xcode and see if that makes a difference. Might as well close the ticket--I'll open a new one if I can find anything useful.

Thanks for the support.

comment:11 Changed 7 years ago by Nigel

Resolution: Works for me
Status: newclosed

I was thinking either filesystem errors, some sort of linker/ccache bug - hence fully disabling ccache, and forcing compiler/linker to exercise disk harder.
Before doing anything drastic on that machine, maybe "Disk Repair" on the hard disk, or open up Console.app and look for filesystem-related errors?

Note: See TracTickets for help on using tickets.