Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10189 closed Bug Report - General (Won't Fix)

Mythnetvision can't download RSS feeds

Reported by: louis@… Owned by: robertm
Priority: minor Milestone: unknown
Component: Plugin - MythNetvision Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The mythnetvision-plugin worked fine in Mythbuntu 10:10 (mythtv 0.23.1+fixes26437-0ubuntu1) however it doesn't work in Mythbuntu 11.04 (mythtv 0.24.0+fixes.20110416.9ba3ece-0ubuntu1) nor Ubuntu 11.10 (0.24.0+fixes.20110908.1de0431-0ubuntu1). I've tried to reinstall Mythbuntu but it didn't help.

When I press "Save this video" in a RSS feed, nothing happens. Before, I was told that the feed was being downloaded when I clicked on it the second time and I could, after some time clicking on it and view it or it started to play automatically after the download was finished if I just leaved the machine.

Some output form /var/log/mythtv/mythfrontend.log:

2011-06-13 16:16:11.704 RSSSite: Updating RSS Feed TechSNAP 2011-06-13 16:16:11.704 RSSSite: Updating RSS Feed The Linux Action Show 2011-06-13 16:17:09.169 RSSSite: Updating RSS Feed So ein Ding 2011-06-13 16:17:09.170 RSSSite: Updating RSS Feed TechSNAP 2011-06-13 16:17:09.170 RSSSite: Updating RSS Feed The Linux Action Show 2011-06-13 16:17:27.424 Downloading /home/louis/.mythtv/download_46079_23274.mp4 2011-06-13 16:20:39.293 MythUIWebBrowser: Loading css from - file:///usr/share/mythtv/themes/default/htmls/mythbrowser.css 2011-06-13 16:20:39.297 MythUIWebBrowser: enabling plugins 2011-06-13 16:20:44.208 Downloading /home/louis/.mythtv/download_18204_57971.mp4 2011-06-13 16:24:08.432 Downloading /home/louis/.mythtv/download_18204_57971.mp4

The download-files mentored in the log file (/home/louis/.mythtv/download_18204_57971.mp4) doesn't exist. It had worked before the update to Ubuntu 11.04 (from mythtv 0.23.1+fixes26437-0ubuntu1 to mythtv 0.24.0+fixes.20110416.9ba3ece-0ubuntu1) as mentored earlier.

The dates in the log file is old because I've previous reported this bug on Ubuntu's Launchpad but concluded that is most likely have to be an upstream bug and after browsing MythTV's ticket system I concluded that this bug likely isn't reported yet or fixed. I think that this bug exist in mythtv 0.24 and upwards but didn't appeared in mythtv 0.23 and 0.23.1

Change History (2)

comment:1 Changed 7 years ago by robertm

Resolution: Won't Fix
Status: newclosed

This functionality has been substantially reworked in master, but I will not be backporting the new functionality to .24. In fact, since it's possible to view the downloadable videos directly in the internal player, there's almost no point in downloading them (though the download code has been rewritten).

comment:2 Changed 7 years ago by Louis Tim Larsen <louis@…>

Thanks for the quick answer. I find the interneal player quite unstable do to Flash. Anyway nice to know that this have been rewritten and will work correctly in the next release. Until then I'll download the shows directly from my PC and transfer them to my Mythtv box though SSH.

Note: See TracTickets for help on using tickets.