Opened 8 years ago

Closed 8 years ago

#10220 closed Patch - Bug Fix (fixed)

[PATHCH] dtvrecorder fix mingw cross compile

Reported by: Lawrence Rust <lvr@…> Owned by:
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords: dtvrecorder mingw
Cc: Ticket locked: no

Description

The current git master dtvrecorder.cpp doesn't cross compile with mingw32 version 4.2.1.

The problem is in the function ts_to_qdatetime which uses a 64-bit constant but doesn't append a trailing LL to denote it as such.

The attached patch fixes this.

Attachments (1)

dtvrecorder-w32.diff (510 bytes) - added by Lawrence Rust <lvr@…> 8 years ago.

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by Lawrence Rust <lvr@…>

Attachment: dtvrecorder-w32.diff added

comment:1 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: newclosed

Fix a 32-bit compilation issue with dtvrecorder.cpp

Manifested itself as the following error on my system:

"error: integer constant is too large for ‘long’ type"

Also reported to be an issue for some when compiling for Windows.

Fixes #10220 using 'LL' instead of the included patch since we use 'LL' elsewhere.

Branch: master Changeset: a4c9072a3371212cf47e912bbf7bd24a700d5d8b

Note: See TracTickets for help on using tickets.