Opened 8 years ago

Closed 5 years ago

#10280 closed Patch - Bug Fix (Works for me)

Quick manual channel selection in tv browse mode doesn't work if there is no 'browse all channels' option activated

Reported by: dluzin@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The problem occurs if you are in LiveTV channel browse mode, have "Setup"->"Video"->"Playback OSD"->"Browse all cahnnels" off, "Setup"->"Video"->"Playback OSD"->"Always use browse mode in Live TV" on, have more than one card per source and trying to enter channel number manually. After you finish entering the channel number it just disappeares from the screen without putting entered channel to browse OSD.

There are actually two problems resides in two places:

  1. tv_play.cpp, function TV::CommitQueuedInput?, line around 12374, ctx->playingInfo->GetSourceID() always returns '0' because playingInfo.sourceid is not set (I was'nt able to find where it should be set, so my solution is to get sourceid by a different way)
  1. tvbrowsehelper.cpp, function TVBrowseHelper::TVBrowseHelper, around line 52 - during querying all channels list for cardid and sourceid comparision 'GROUP BY "channum, callsign"' drops all result rows with same channel numbers leaving just the first one (in my case one source has 4 cardid's, so each channel in this source has to have 4 cardids), so I just added "cardid" as additional GROUP BY parameter.

So I'm attaching a small patch that solves above mentioned problems and allows to use 'quick channel selection in browse mode'. Best regards, Dennis

Attachments (2)

browse.patch (1.3 KB) - added by dluzin@… 8 years ago.
browse.2.patch (1.3 KB) - added by dluzin@… 8 years ago.
corrected patch

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by dluzin@…

Attachment: browse.patch added

Changed 8 years ago by dluzin@…

Attachment: browse.2.patch added

corrected patch

comment:1 Changed 6 years ago by stuartm

I can't reproduce this in 0.27, could you please confirm that this bug still exists?

comment:2 Changed 6 years ago by stuartm

Status: newinfoneeded_new

comment:3 Changed 5 years ago by sphery

Resolution: Works for me
Status: infoneeded_newclosed

Was reported working in 0.27, and no confirmation/disagreement from original reporter in 7 months.

Note: See TracTickets for help on using tickets.