Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10386 closed Bug Report - General (fixed)

Segfault When Starting FE With --jumppoint "Live TV"

Reported by: Bill Meek <keemllib@…> Owned by: Jim Stichnoth
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Submitted on behalf of warped from the #mythtv-user's list. His failure was on a diskless client and wasn't easily able to get a backtrace. In my two tests, both dropped core with the same one line backtrace (the core file was 24MB.

warped is currently running on: a3d9891 and believes the failures to have started with: 307dac8776.

Duplicated with:

ulimit -c unlimited
mythfrontend --jumppoint "Live TV" --quiet \
    --nodblog -v general --loglevel debug --logpath /var/log/mythtv

Attachments (2)

mythfrontend.20120226084900.26741.log (11.6 KB) - added by Bill Meek <keemllib@…> 8 years ago.
version.txt (759 bytes) - added by Bill Meek <keemllib@…> 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Bill Meek <keemllib@…>

Changed 8 years ago by Bill Meek <keemllib@…>

Attachment: version.txt added

comment:1 Changed 8 years ago by warpme@…

Hi, FYI Bisecting code shows that issue is caused by 307dac8776. Reverting this commit gives no segfaults.

comment:2 Changed 8 years ago by Jim Stichnoth

Milestone: unknown0.25
Owner: set to Jim Stichnoth
Status: newaccepted

comment:3 Changed 8 years ago by Github

Resolution: fixed
Status: acceptedclosed

Fixes #10386. Segfault fix. Check for null.

Branch: master Changeset: 7e6f5fa665a4c02d9c5f251dabd2825a6efed193

comment:4 Changed 8 years ago by Github

Refs #10386. Don't sent EXIT_TO_MAIN event to Live TV jump point.

While 7e6f5fa66 fixes a segfault, that section of code shouldn't have been executed -- it's not a good idea to dispatch an EXIT_TO_MAIN event right before starting playback. Therefore, don't dispatch the event if the jump point starts from the main menu.

Branch: master Changeset: 99512fb5229179cf65cf00649b7f7c0271aa9372

Note: See TracTickets for help on using tickets.