Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#10403 closed Bug Report - General (fixed)

Pressing ESC in main menu just exit

Reported by: jyavenard Owned by: mdean
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

A regression that only started recently. Not sure when.

When pressing ESC in the main menu , it simply exits mythfrontend instead of showing up the confirmation + asking what to do pop-up

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by mdean

  • Owner set to mdean
  • Status changed from new to accepted

comment:2 Changed 2 years ago by Github

Remove limit from 1256 DB update.

The limit, coupled with a post-0.24 DB upgrade, could cause a key
binding collision on exactly one host (and not more than one host) in
the MythTV system when upgrading from a 0.23 schema version to post 0.24
schema version. The collision could only occur in a multi-host MythTV
system, could not occur on the host performing the DB upgrade(s), and
could only occur on a host that had been used as a frontend with 0.23
but never ran either mythfrontend or mythtv-setup from 0.24.

More specifically, you would have had to have a schema version from
before May 10, 2010 on master (such as a 0.23 schema version) and
upgraded to a schema version from after July 21, 2011 on master (not in
any released version, but will be in 0.25) without ever running a
version of mythtv from between those 2 dates. Even then, the collision
is unlikely to occur because of how the data is returned.

For users running master, any affected host's mythfrontend or
mythtv-setup will show the warning:

2012-03-06 09:08:55.862679 W Key Esc is bound to multiple actions in
context Main Menu.

The collision can be fixed by manually removing or changing the binding
on the action you don't want in mythfrontend's Utilities/Setup?|Edit Keys
in the Main Menu context on the affected host.

For users running 0.24 versions, there is no collision, and simply
running mythfrontend (or mythtv-setup, but no need to run both) from
0.24-fixes on your frontend hosts will prevent one from occurring when
you upgrade to 0.25, so you have nothing to worry about/nothing to fix.

Refs #10403.

Branch: master
Changeset: e022c2c9769f53a78355d1bb5950bf33593cfbad

comment:3 Changed 2 years ago by Github

  • Resolution set to fixed
  • Status changed from accepted to closed

Prompt on exit if configuration is ambiguous.

Make EXITPROMPT take precedence on systems where it is mapped to the
same key as EXIT.

Fixes #10403.

Branch: master
Changeset: 1558b6ea8b6911c4db703c2ca11e976fc45b4a0a

comment:4 Changed 2 years ago by mdean

While e022c2c97 fixes an issue that could have resulted in this behavior for a single host in a multi-host MythTV system under a very strict set of conditions (that were not met by any of those who reported seeing this issue), it is almost definitely not the source of the issue. Since the DB update that would have caused this collision occurred 7 months prior to the first report of this issue (on Feb 24, 2012) and since this issue has been reported by multiple people in the past 2 weeks and reported to occur on multiple hosts that have run versions of MythTV 0.24, there is almost definitely something else breaking key bindings configuration.

However, with the information given, I can not find any other code that could cause the issue. So, 1558b6ea8 works around the issue by making it "invisible" to the user, except for the log message telling them that their key bindings are broken. I would very much like to find the root of the problem, but doing so will require more information about the conditions that resulted in the issue. I would be very happy to receive that information from any user who notices the key binding collision on their system (though I realize that it's far less likely users will notice now that the symptom of the issue is less visible).

Therefore, I closed the ticket. Again, though, I would be pleased to receive additional information--please send that information to the mythtv-users or mythtv-dev mailing list--if anyone can help narrow down the true source of the issue. Thanks.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.