Opened 6 years ago

Closed 6 years ago

#10442 closed Bug Report - General (Fixed)

MythFrontend jittery video playboack on 2010 Mac mini

Reported by: joenyland@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: 0.24.2
Severity: medium Keywords: mac frontend
Cc: Ticket locked: no

Description

I have posted this to the mythtv-users mailing list, but unfortunately no-one has been able to offer any advice, other than installing Ubuntu on the Mac mini, which isn't a solution.

Basically, 95% of the channels and recordings I watch (both live TV and recordings) have jittery playback - no pixelation, but motion is not fluid. This makes 95% of the stuff I watch/record in MythTV unwatchable on my Mac mini, which is my main frontend system.

I am able to play back the same recordings files on the same system in XBMC (via MythTV's UPNP), VLC (again, via UPNP) and on other frontends too, without any issues.

There seems to be some issue with MythTV's ability to utilise the GPU on my model of Mac mini, where other applications can utilise it fine. I can play back 1080p content with all the bells and whistles in the likes of XBMC, etc. so the GPU is definitely capable of what I am giving it.

Primary frontend Mac mini (Mid 2010) Core 2 Duo 2.4 GHz CPU 4GB RAM 1067 MHz DDR3 NVIDIA GeForce? 320M 256MB GPU OS X Lion (10.7.3) MythFrontend jyavenard/backports/fixes/0.24 [v0.24.2-216-g247c4f1-dirty]

Backend Dell PowerEdge? T110II Xeon E31230 3.2 GHz (Quad core +HT) CPU - 4 cores assigned to MythTV backend server 1GB RAM 1333MHz DDR3 assigned to MythTV backend server Recordings stored on 3 1TB Seagate drives in md RAID5 Ubuntu 10.04 LTS x64 MythBackend? fixes/0.24 [v0.24.2-19-g02dd6ee] HDHomeRun HDHR3 as the TV source - UK Freeview, so SD quality

I should be able to post a sample clip later on, as I believe this will help support my description of the issue.

If there are any other logs/versions/traces that I could provide, which would be useful, please let me know.

Thanks,

Joe

Change History (3)

comment:1 Changed 6 years ago by JYA

There is no GPU acceleration in myth 0.24 on the mac. This is a feature that will only be available on 0.25

Having said that, video plays nicely on my macbook air, which is far less powerful than a mini.

On Lion, I have noticed Qt issues that are only resolved if mythfrontend was compiled against Qt 4.8. Unfortunately, the sourceforge autobuild package are compiled against Qt 4.6.3. This works well on pre-Lion machine only

comment:2 Changed 6 years ago by joenyland@…

Some updates from my end from further testing tonight:

  • If I set the resolution on my iMac to 1920x1080 (same resolution as the Mac mini which I am having problems with) I get the exact same behaviour. - motion is jittery even though this is a far more powerful machine.
  • If I set MythFrontend to fullscreen on my iMac 2560x1440, I do not get the issue.
  • If I set the resolution to 1440x900 on my iMac, I do not get the issue.

Therefore, the issue I am describing only seems to be there when MythFrontend is set to use 1080p resolution - 1920x1080.

I do not see any other display issues which jyavenard mentions above, apart from this.

comment:3 Changed 6 years ago by JYA

Resolution: Fixed
Status: newclosed

OP reported it fixed in 0.25

Note: See TracTickets for help on using tickets.